Results 1 to 8 of 8

Thread: New suspension install - still help needed

  1. #1
    Join Date
    May 2004
    Location
    Sydney, Australia
    Posts
    2,699

    Default New suspension install - still help needed

    Got h&r springs matched with koni adustables replacing my stock 210,000 km setup. Sits lower for a more agressive look. This car loves corners. Not much room from underneath the car to the ground. The ride is firmer but still absorbs bumps well. Got the front on fully soft and don't know about the rears. It greatly improves the handling of the car. I love it.

    I'm hearing a "clunking" sound in the front suspension when going over bumps in the road at lower speeds (about 30 kms), this was happening before the new suspension setup.

    Ive had the bushes replaced in the thrust arms to no avail. Any help guys?
    Attached Images Attached Images  

  2. #2
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    with the work that's listed to have been done, id guess the sway bar links are it
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  3. #3
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,774

    Default

    id guess that the strut collar nuts arent tightened enough, how tight did you spin them?
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  4. #4
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    he said it did it before and after suspension or i would of brought up the collars

    Quote Originally Posted by 632 Regal
    id guess that the strut collar nuts arent tightened enough, how tight did you spin them?
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  5. #5
    Join Date
    Dec 2003
    Location
    Austin, TX
    Posts
    1,181

    Default

    lack of oil in the strut casing.
    1995 540iA M-Sport - 76k miles. 1 of 1 auto AW3 cars.
    1995 540i/6 - Misc Parts donor for above.

  6. #6
    Join Date
    May 2004
    Location
    Sydney, Australia
    Posts
    2,699

    Default

    thanks for the info.. I'll look into it winfred

  7. #7
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,163

    Default had the same prob till 2 weeks ago and changed

    these items and it works fine now. No more 'clonk'

    read here

  8. #8
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,774

    Default

    ok, re-reading his stuff I might have an idea. You say you had new thrust arm bushings pressed in, how are the balljoint ends? If they are loose thats a problem, what condition is the control arms and bushings in?
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

Similar Threads

  1. New suspension install, rear end feels bouncy
    By Tiger in forum 5 Series BMW
    Replies: 34
    Last Post: 06-13-2008, 08:57 PM
  2. suspension help needed
    By markus in forum 5 Series BMW
    Replies: 4
    Last Post: 11-09-2006, 11:17 PM
  3. Some pic's after suspension install:
    By E34 530 in forum 5 Series BMW
    Replies: 27
    Last Post: 06-12-2006, 02:03 AM
  4. Admin rights needed for ETK/TIS install....?
    By Bellicose Right Winger in forum 5 Series BMW
    Replies: 15
    Last Post: 10-13-2005, 09:34 PM
  5. New Suspension Needed......
    By western99 in forum Suspension & Steering
    Replies: 3
    Last Post: 03-18-2005, 12:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •