Results 1 to 4 of 4

Thread: '94 530iT Won't Stay Running

  1. #1
    Join Date
    Sep 2004
    Posts
    2

    Default '94 530iT Won't Stay Running

    My '94 530i will not run with the MAF sensor connected. It idles as if the timing or mixture is way off. Eventually, it dies. Upon playing with it I discovered if I electrically disconnected the MAF sensor the car would run fine. (After it warmed up a little.) I replaced the MAF sensor and the same thing happens. Obviously, it is not the sensor. I can not pull any codes out of the ecu. (I don't seem to have the knack for the 5 floorings of the accelerator in 5 seconds.) The check engine light is not lit with the MAF connected but does illuminate when the MAF sensor is disconnected. Any ideas as to what is wrong?

    Maybe this is another clue, I get great gas mileage without the MAF sensor when on the highway; 28MPG. Normally it is about 24.5 on the highway.

    Any help would be appreciated!

    Mark

  2. #2
    Join Date
    Aug 2004
    Location
    Houston
    Posts
    15

    Default

    idle stabilizer perhaps? i'm not an expert, but in know that if this electrically powered thing is no operating the idle is affected significantly. hoepfully i haven't embarrased myself here...is the MAF the idle stabilizer? bob in houston.

  3. #3
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,774

    Default

    ICV problem perhaps a loose fitting
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  4. #4
    Join Date
    Sep 2004
    Posts
    2

    Default '94 530iT Won't Go

    I don't think it is the ICV because the car idles fine without the MAF sensor being connected. I think it would still die with or wtihout the MAF sensor if the ICV were not working. Also, cracking the throttle by hand (or foot!) should allow it to idle with a bad ICV. (I think the ICV is a bypass air type, right?) But the car will not run for more than a few seconds with the MAF sensor (electrically) connected. It is as if the sensor is giving the ECU totally bogus information and it does not know how to compensate for it.

Similar Threads

  1. why won't my sun visor stay up all the way?
    By timandbim in forum 5 Series BMW
    Replies: 5
    Last Post: 01-12-2008, 03:06 AM
  2. Ok, I'm ready to beg for help. E34 won't stay running.
    By Bin_jammin in forum 5 Series BMW
    Replies: 15
    Last Post: 07-13-2007, 06:16 PM
  3. A/C Vents Won't Stay Put!
    By we_call_him_doher in forum 5 Series BMW
    Replies: 12
    Last Post: 06-08-2006, 07:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •