Results 1 to 9 of 9

Thread: dashboard electronics problem + car start problems

  1. #1
    Join Date
    Feb 2005
    Location
    Bristol, England
    Posts
    7

    Default dashboard electronics problem + car start problems

    Hi,
    I fitted a new CD stereo in my BMW 525 td yesterday and ever since the Diesel gauge on my car doesn't move anymore when you switch the engine on. Others things that don't light up on the dashboard are the electronic mileage counter.

    When I turned the engine on yesterday after installing the stereo there was a funny ticking noise coming from the battery compartment in the engine.

    I used the car about two hours later, the car started got about 20 metres down the road and then cut out, I haven't been able to start it since.

    Does anyone know what the problem way be?? I'm not entirely sure if the two things are related. I can't see how installing a new stereo can stop my car from starting!! And I really don't understand why the electronic displays aren't working on my dashboard.

    Please help.

    Cheers
    Spaceboyo

  2. #2
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,168

    Default

    I assume that you did not connect or wrongly connect the speed signal wire.

    Whatever the problem is, it most probably came from your installation. So I would remove everything in the dashboard and check the wiring you have done.

  3. #3
    Join Date
    Feb 2005
    Location
    Bristol, England
    Posts
    7

    Default

    The dashboard electronics actually stopped working before I installed the new stereo. I took out the new one, drove to my local car shop to buy a iso connector cause the bmw one had been hacked off. The electronics were working on the way to the shop but not on thw way back!

    Is the car not starting and cutting out on me related to this too??

    Cheers
    Spaceboyo

  4. #4
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,168

    Default

    Try to allocate the ticking noise in the engine room. Maybe it is a stuck relay, maybe even the relay for the fuel supply, or better to say in your case for the diesel.

  5. #5
    Join Date
    Feb 2005
    Location
    Bristol, England
    Posts
    7

    Default

    What about the electronic dials on the dashboard??

    One minute it was working the next it wasn't!!

    Cheers
    Spaceboyo

  6. #6
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,168

    Default

    Did you check the fuses? Change them even if they look good.

  7. #7
    Join Date
    Feb 2005
    Location
    Bristol, England
    Posts
    7

    Default

    I'll have to do that tomorrow.

    Do you think the two things are related in anyway.

    If my Fuel gauge is not working does that stop the car from starting??

    I'm just really confused how replacing a stereo can cause so much problems.

    I did have to rewire the unit but that was a case of copying what was already there.

    Cheers for your help
    Spaceboyo

  8. #8
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,168

    Default

    If the fuel gauge is not working, that does not matter to start the engine.
    I guess you have blown some fuses or a main fuse.
    I am not sure about the E34, but on the E32 there are also fuses under the rear seat.
    Maybe you check that one out.
    Or go to my page below and look for wiring diagrams, there are also the fuses shown when you look for your model and the production year.

  9. #9
    Join Date
    Feb 2005
    Location
    Bristol, England
    Posts
    7

    Default

    I've changed the dashboard control unit fuse and that now works, I've also changed the fuel pump fuse. The car still doesn't want to start. Might I have damaged one of the relay switches?? I still don't understand how I managed to break the dashboard fuse.

    Cheers
    Spaceboyo

Similar Threads

  1. all these problems lately <:C where to start?
    By [1990]525 in forum 5 Series BMW
    Replies: 5
    Last Post: 12-11-2010, 05:52 PM
  2. Problem fitting CD43 into dashboard
    By JMI in forum 5 Series BMW
    Replies: 2
    Last Post: 07-05-2007, 06:02 PM
  3. Electronics problem
    By wang540 in forum 5 Series BMW
    Replies: 7
    Last Post: 10-11-2006, 12:29 PM
  4. Problems with 525tds dashboard
    By salpa in forum 5 Series BMW
    Replies: 0
    Last Post: 02-11-2006, 05:44 AM
  5. Dashboard removal, airbag a problem?
    By ElNormo in forum 5 Series BMW
    Replies: 7
    Last Post: 02-13-2005, 09:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •