Results 1 to 8 of 8

Thread: Erratic speedometer and tach help.

  1. #1
    Join Date
    Dec 2003
    Location
    No. California
    Posts
    119

    Default Erratic speedometer and tach help.

    My speedometer and tachometer have started to have a mind of there own. Sometimes the speedometer will not read correctly, then the tach will do the same. Sometimes both, other times just the speedo. Checked the archives and only found info relating to speedometer and the speed sensor. Could this be related to a capacitor on the board?

    Any suggestions or help appreciated.

    Kurt
    95 525ia 165k

  2. #2
    Join Date
    Oct 2004
    Posts
    3,395

    Default

    Kurt -

    I've been experiencing problems with my speedo a lot recently, as well. Sometimes it will work fine, others it won't. Now it just doesn't work.

    I consulted Brett Anderson at KMS about it last time he had my car. He said that the capacitors wouldn't affect the speedo, just the gas/temp/etc...He also tested out my dash module as working fine.

    So I bought a new diff speed sensor, but haven't stuck it in yet. Hopefully that will solve the problem. I'd start there on your car - the part is less than $30 from BMA.

    Good luck!

    Best, whit

  3. #3
    Join Date
    Jan 2004
    Posts
    1,342

    Default Don't know, why the tach issue? ...

    speed sensor signal is received by the dash board, processed and sent to all speed dependent devices, including the OBC. Is the OBC working fine? When you get a weird behavior, set the speed limit to the actual speed (set speed limit mode and press S/R). If OBC shows proper speed, there should be no issues with the speed sensor. Vice-versa is not necessarily true.

    Javier

  4. #4
    Join Date
    Feb 2005
    Posts
    1

    Default Try First

    I've just had a simalar problem on a 1988 E34 535. Which by accident, I found the problem to be a broken wire in the wiring loom that feeds along the Rear Boot Lid hinge. When I removed the Plastic protection cover and wrapping from the wiring I found a lot of the wires cracked through ware over the years. Upon repairing these I found I had no futher problems.

  5. #5
    Join Date
    Aug 2005
    Posts
    33

    Default

    My speedo reads 10-15 miles slow. You mentioned something about a wire loom. Where exactly did you find the damaged wires?

    Have you ever heard about re-programming the OBC to correct for speedometer read errors? I don't have complete info on this so if you know of hw to do this please let me know.

  6. #6
    Join Date
    Jan 2004
    Posts
    1,342

    Default Check this link on OBC hidden functions.

    OBC

    Javier

  7. #7
    Join Date
    Aug 2005
    Posts
    33

    Default

    I went to this link and contacted the author for more information. He did not know how to adjust the speedometer. So I'm stuck. Any other ideas?

  8. #8
    Join Date
    Mar 2005
    Location
    Bethlehem, PA
    Posts
    661

    Default

    I'm not so sure Brett Anderson is correct. The switching regulator supplies power to virtually every circuit in the cluster, adn that includes the speedo. Depending on the version of the cluster you have, there may be more than one power supply as well. All clusters have somewhere between four and eight power-related caps that can fail and cause trouble. When I rebuilt mine earlier this year, I found that three out of the six most vulnerable were degraded. One was completely open and two others had only about 1/4 of their rated capacity. They trouble they caused extended beyond the cluster itself, too. In my case -- and I know this sounds farfetched -- the noise emitted by the switching regulator seriously degraded AM radio reception. Otherwise, the tach, fuel, trip odo, and mileage meters all had occasional spates of insanity.

    IMO, and speaking as someone with an EE degree and who used to design things not too different from what's in that cluster, you should fix first what you know, or strongly suspect, is wrong. And in this case that means opening the cluster and replacing the caps.

Similar Threads

  1. Lazy Tach
    By repenttokyo in forum 5 Series BMW
    Replies: 2
    Last Post: 03-07-2008, 08:32 PM
  2. Tach(?) noise
    By blee in forum 5 Series BMW
    Replies: 1
    Last Post: 08-01-2006, 12:28 PM
  3. Need Help! Please! Asap!...tach Stuck
    By bimmer253 in forum 5 Series BMW
    Replies: 2
    Last Post: 02-29-2004, 08:08 PM
  4. What would cause the tach to read incorrectly?
    By mancini_mark in forum 5 Series BMW
    Replies: 5
    Last Post: 02-27-2004, 09:15 PM
  5. Erratic Speedometer
    By Unregistered in forum 5 Series BMW
    Replies: 1
    Last Post: 02-17-2004, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •