Results 1 to 4 of 4

Thread: Service II

  1. #1
    Join Date
    Oct 2004
    Location
    Eaton, Colorado
    Posts
    10

    Default Service II

    1990 525i (M20) 5spd w/184,000 miles.

    I plan on doing a full (Bentley in hand) Service II including replacement of the timing belt/water pump and all other belts & fluids and O2 for the first time. In addition to asking for advice for a first timer I'd like to ask if anyone knows what pully bearings up front are prone to going bad. My car has a pulley noise up front that I can't locate for sure. It's not a belt slipping or a vacuum leak, but that constant whine you usually hear coming from a Ford POS. I'd really like to fix the wheezing sound while I have everything torn down up front.

    Also, what is the best oil for the manual trans?

    Thanks for your help!

  2. #2
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,774

    Default

    does the whine increase when you turn the lights on? Look into the alternator if so, could also be a low battery or a bad diode in the alternater which new brushes will not cure.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  3. #3
    Join Date
    Oct 2004
    Location
    Eaton, Colorado
    Posts
    10

    Default

    Quote Originally Posted by 632 Regal
    does the whine increase when you turn the lights on? Look into the alternator if so, could also be a low battery or a bad diode in the alternater which new brushes will not cure.

    It's not the alternator - thankfully. I know what that sounds like (E36 in my not too distant past). I'm sure it's a pulley bearing, but I can't pinpoint which one it is.

    BTW - do you have a keyless set up on your ride? I have the same lock problem you do. I put one in a month or so ago (using Bruno's site/bentley - et al as a guide) hoping to get around the problem, but it's not working. Everything else works such as the light flash, but the locks don't work. It's an aftermarket kit as my car wasn't prewired. Multimeter says the unit is working, but the locks say otherwise.

    Thanks again!

  4. #4
    Join Date
    Jan 2004
    Posts
    4,148

    Default Could be the timing belt tensioner pulley or any of the others, I would

    remove the belts and spin the accys. over by hand to see which is making noise.. could be water pump, A/C pulley bearing, power steering pump, alt..You won't know until you take the belts off and spin them.. Or if you have a good ear you can use a mechanics stethoscope or a long piece of tubing or a long screwdrive that you can put up against the suspected items an put your ear against the other end and listen for the noise while its running but extreme caution must be used while doing this for obvious reasons.





    Quote Originally Posted by Shimamura3
    1990 525i (M20) 5spd w/184,000 miles.

    I plan on doing a full (Bentley in hand) Service II including replacement of the timing belt/water pump and all other belts & fluids and O2 for the first time. In addition to asking for advice for a first timer I'd like to ask if anyone knows what pully bearings up front are prone to going bad. My car has a pulley noise up front that I can't locate for sure. It's not a belt slipping or a vacuum leak, but that constant whine you usually hear coming from a Ford POS. I'd really like to fix the wheezing sound while I have everything torn down up front.

    Also, what is the best oil for the manual trans?

    Thanks for your help!

Similar Threads

  1. Service Indicator
    By Golgade in forum 5 Series BMW
    Replies: 4
    Last Post: 05-14-2008, 12:58 PM
  2. Anybody have the car fax service right now?
    By BennyM in forum 5 Series BMW
    Replies: 1
    Last Post: 12-20-2007, 10:33 AM
  3. Z3 service lights
    By suuntobob in forum Z3/Z4 Forum
    Replies: 2
    Last Post: 03-08-2007, 01:11 PM
  4. Replies: 6
    Last Post: 01-22-2007, 11:56 PM
  5. Montreal : BM Service Exclusif (BM Exclusive Service)
    By BMWDriver in forum Recommended Bimmer Repair Facilities
    Replies: 0
    Last Post: 11-26-2005, 11:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •