Results 1 to 5 of 5

Thread: '91 535 IHKA issues

  1. #1

    Default '91 535 IHKA issues

    Does anyone have information on how to repair or find a new IHKA-II unit for the '91 535. I do not believe any other years will fit, or maybe late '90 to early '92. The problems with the unit cause the A/C, Recirc., or the R. Defroster not to work. I have ruled out that it is the three switches. Any help would be greatly appreciated.

    Thanks,
    Tim

  2. #2
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,091

    Default

    Have you checked the IHKA control module?
    Look for 'cold' solderings. Resolder and check again. Maybe that helps.

  3. #3

    Default

    Quote Originally Posted by shogun
    Have you checked the IHKA control module?
    Look for 'cold' solderings. Resolder and check again. Maybe that helps.
    Yeah, I took the IHKA unit apart, i did find a Thermistor not properly connected, but i did resolder it, but same symptoms. The circuit board it covered with a red sealant type substance that's nearly impossible to pick through.

  4. #4
    Join Date
    Jan 2004
    Posts
    1,342

    Default Have you considered you may have a faulty ....

    unloader relay, preventing the A/C, and the rear defoger to work. Just a wild guess. There is a recent post about "No Battery warning light" that may help you identify this relay.

    Javier

  5. #5
    Join Date
    Mar 2004
    Posts
    454

    Default

    Quote Originally Posted by botardtim
    Does anyone have information on how to repair or find a new IHKA-II unit for the '91 535. I do not believe any other years will fit, or maybe late '90 to early '92. The problems with the unit cause the A/C, Recirc., or the R. Defroster not to work. I have ruled out that it is the three switches. Any help would be greatly appreciated.

    Thanks,
    Tim
    Tim,
    I had a similar problem with my IHK (95 though) in that the AC and rear defogger would work at idle but as soon as I got some RPM's they would kick off. I bought a used one using junkyard dog from Wash state for 130$ with a 1 year warranty. The "new" unit fixed me right up (and I had given up on ever fixing the AC as I could not justify spending big bucks for someone to look at that system). In my case, I think the power regulation failed but no easy way to check due to all of the coating on the board.

    Scott
    1995 BMW 525i w/139K miles, EAT Chip - (Gone)
    07 525i 22K, 07 328xi (41K)
    1982 Mazda RX-7 w/147K miles (Back again!)

Similar Threads

  1. e32 IHKA fault
    By myles in forum 5 Series BMW
    Replies: 2
    Last Post: 02-26-2015, 04:31 PM
  2. Replies: 16
    Last Post: 01-25-2008, 02:47 PM
  3. E38/39/36/46 IHKA Details
    By shogun in forum 7 Series BMW
    Replies: 0
    Last Post: 12-30-2006, 02:05 AM
  4. IHKA compatibility issues...
    By Montreal525 in forum 5 Series BMW
    Replies: 4
    Last Post: 10-27-2006, 03:55 AM
  5. ihka or ihkr?
    By Paul in NZ in forum 5 Series BMW
    Replies: 5
    Last Post: 10-21-2005, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •