seems the E32 Bentley manual is wrong, also for the E34, copied from BF

See #'s 8 and 10 in the diagram below from this page: https://www.realoem.com/bmw/enUS/sho...diagId=11_4638
08 Engine coolant temp sensor 2-POL 12621710535
10 Temperature sensor, water M14X1,5 12621288158

Assuming one of them is for the temp gauge and one goes to the ECU, I want to buy the one for the ECU. Then again there is also a temp sensor in the side of the radiator. Does that go to the temp gauge? If so why are there two on the engine? I'm so confused, please help!
-------------
accdg to Bentley repair manual page 170-4
10 Temperature sensor, water M14X1,5 12621288158 , the one towards the fender temperature gauge sender
08 Engine coolant temp sensor 2-POL 12621710535 engine coolant temperature (ECT) sensor DME

coolant temperature sensor wire colors M60:
gauge sender: brown/violet- brown/yellow
ECT sensor DME: yellow/green -brown/orange

You could also warm up the car, shut it off, put key in pos 1, then disconnect the plugs one at a time while monitoring the temp gauge to see which one does what. It does matter as both sensors have different resistance characteristic curves. the temperature sensor at the side of the radiator is for the auxiliary fan for hi and low speed switching
----
Not to make this more confusing, but this might be helpful for other who come across this thread in the future, the E32 and E34 Bentley manual either has an error, or the location of the two coolant temp sensors was at some point swapped on both my e32's at some point. Bentley shows the sensor closest to the passenger side fender is the instrument cluster sensor and the one more inboard is the DME coolant sensor. On both of my cars it is the opposite. In the end it doesn't really matter which sensor is in which hole as long as the correct plugs of the wiring harness are connected to the correct sensor...

Note that the realoem diagram shows the DME sensor as the one closer to the passenger fender. I recently replaced both these sensors and out of curiosity I checked the wiring to each plug for the DME and gauge cluster coolant temp sensors and the wire colors didn't even match what the BMW wiring diagrams show. Ultimately I knew which plug was for the DME (white plug) and gauge cluster (black plug), and the sensors themselves at least if bought from BMW, are labeled 'Bosch' for the DME, and 'VDO' for the gauge cluster. Another thing to note - the original DME coolant temp sensor was white, however the current one BMW sells now has a black top...
------------
good find, additional info, corrected, most important the ohms, wherever the sensor is located, use them by ohm to connect to DME or gauge, test the senders ohms before installing them.
Temperature Sensor 20 deg. C, 2500 Ohm. White Top (usually), 12621288158 is for the DME, ohm values at different temperatures here http://www.e32-schrauber.de/bmw/date...u-2_5-kohm.png
12621710535 black top, M14 x 1,5, Ohm:5000, goes to the cluster.

table Bosch 5kOhm Sensor, NTC 5kOhm at 25C +/-2%
Temp C.....R Ohm
-30........... 88.700
-25 ...........65.300
-20 ...........48.500
-15 ..........36.400
-10 ..........27.600
-5 ...........21.100
0 ............16.300
5 ............12,700
10 ............9.300
15 ............7.800
20 ............6.200
25 ............5.000
30 ............4.000
35 ............3.200
40 ...........2.600
45 ...........2.100
50 ...........1.800