Results 1 to 5 of 5

Thread: Speedometer, odometer, fuel effiency stopped working

  1. #1
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,649

    Default Speedometer, odometer, fuel effiency stopped working

    Worked when I left and then just stopped. I didn't try the cruise control tho. Wipers work. All fuses work except 10, 11, 13 and 14 which do have power when I turn the lights in regards on.

    Tried the disconnect battery and then after that didn't work did it again and shorted + &- no deals.

    I kinda suck at electrical so schematics don't really help. Seems like a relay is dead somewhere. I haven't had enough time to reset them all yet though. Read a lot in regards to speed sensor in the rear differential which I have not ventured into.

    Any other obvious things I should look into? Never had any issue like this besides the power amp fluking out on me.
    95 E34 530I V2.17
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  2. #2
    Join Date
    May 2006
    Location
    NH
    Posts
    2,059

    Default

    Quote Originally Posted by 632 Regal View Post
    Worked when I left and then just stopped. I didn't try the cruise control tho. Wipers work. All fuses work except 10, 11, 13 and 14 which do have power when I turn the lights in regards on.

    Tried the disconnect battery and then after that didn't work did it again and shorted + &- no deals.

    I kinda suck at electrical so schematics don't really help. Seems like a relay is dead somewhere. I haven't had enough time to reset them all yet though. Read a lot in regards to speed sensor in the rear differential which I have not ventured into.

    Any other obvious things I should look into? Never had any issue like this besides the power amp fluking out on me.
    Only idea I have is to ask if there is possible water incursion to the driver side floor/footwell.

    At the left corner, under the carpet is a big yellow wire connector with bunches of wires..

    I had holes in floorboards allow water inside which corroded soem wires and lost many things like radio, tail lights, dome /map lights and speedo.. had to splice and twist a few wires and all was good.
    1995 540i Manual build 1/95

  3. #3
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,649

    Default

    No water inside, think it's the pulse generator. Supposed to check it out later when my son gets back.
    95 E34 530I V2.17
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  4. #4
    Join Date
    Sep 2007
    Location
    Michigan
    Posts
    335

    Default

    The plug at the pulse generator would be suspect. I've had to replace two on similar vintage e30's.

    1990 535im 421,000 miles, 1987 325is, 1989 325is, 1990 m3, 1991 318is, 2001 X5 3.0

  5. #5
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,649

    Default

    Got it on ramps and looked at it, one wire was broke off right at the connector. Soldered it and put liquid tape on it and good as new.

    95 E34 530I V2.17
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

Similar Threads

  1. My radio stopped working and red light stopped flashing.
    By William Henson in forum 5 Series BMW
    Replies: 2
    Last Post: 07-29-2012, 10:36 PM
  2. odometer stopped at 300k
    By Mendozart in forum 5 Series BMW
    Replies: 28
    Last Post: 11-01-2008, 02:41 PM
  3. Horn Stopped working...!?
    By Ferret in forum 5 Series BMW
    Replies: 10
    Last Post: 09-11-2007, 12:44 PM
  4. Speedometer not working
    By Keith W in forum 3 Series BMW
    Replies: 4
    Last Post: 11-24-2006, 11:28 PM
  5. A/c stopped working
    By DukeNeverwinter in forum 5 Series BMW
    Replies: 5
    Last Post: 10-13-2005, 04:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •