Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Radio sound dead

  1. #21
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,269

    Default

    When you say older amp, if you mean one that came from a car with M20/M30 and Hi-Fi sound, I am sure you cannot!

    If you mean one from an M50/M60 car with Hi-Fi sound, I think yes.

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

  2. #22
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,522

    Default

    Scored this from a 94 540 today:



    Is different but the connections appear to be the same.
    95 E34 530I V2.17
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  3. #23
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,522

    Default

    Well the new old one kinda works if you play with the fine pin connection. Wont work loose and wont work connected, somewhere in the middle I get rear and right and left but not all together. Used Gordons Stabilant 22 and no change. Put the old amp back in and still works. Son is thinking the solder connections to the small pins are compromised on the one we just scored. At least we can see that compared to the old one. If no deal I can return and score more free stuff lol.
    95 E34 530I V2.17
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Radio dead after telephone removal / OBC PPPP Code
    By 632 Regal in forum 5 Series BMW
    Replies: 3
    Last Post: 04-28-2014, 11:46 AM
  2. No sound from Radio
    By caf2461 in forum 5 Series BMW
    Replies: 5
    Last Post: 09-10-2012, 07:40 PM
  3. Radio turns on, but no sound?
    By rcbrown23 in forum 5 Series BMW
    Replies: 12
    Last Post: 08-21-2007, 04:29 PM
  4. OEM radio has power, no sound...
    By 91bmw525i in forum 5 Series BMW
    Replies: 22
    Last Post: 03-03-2005, 02:06 PM
  5. factory radio is dead...what works with the changer?
    By RIPN RAY in forum 5 Series BMW
    Replies: 10
    Last Post: 12-30-2004, 12:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •