Page 6 of 6 FirstFirst ... 456
Results 51 to 57 of 57

Thread: Radio sound dead

  1. #51
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default

    I understand that. I failed to take pictures of the issue I had getting access. I figured after removing the heat sink clips it would come apart but it wouldn't. Funny, I couldn't get it apart and don't want to break it even though it's never going to be used by me again. If I forced it any more it would have broke the circuit board/s.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  2. #52
    Join Date
    Jan 2013
    Posts
    19

    Default

    So send it to me and I will try to repair it.

  3. #53
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default

    Send me a message.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  4. #54
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default

    Name:  IMG_0440.jpg
Views: 14
Size:  86.9 KBName:  IMG_0436.jpg
Views: 14
Size:  58.5 KBName:  IMG_0437.jpg
Views: 14
Size:  49.0 KBName:  IMG_0438.jpg
Views: 14
Size:  57.6 KBName:  IMG_0439.jpg
Views: 14
Size:  37.8 KB
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  5. #55
    Join Date
    Jan 2013
    Posts
    19

    Default

    Looks easy enough to open. There are screws holding it together.

    That one is different from mine. But fixing it should be easy enough; it's just that I don't think it would work in my car.

  6. #56
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default

    Yeah I had it apart, just cant get to the part where the plugs connect to the boards.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  7. #57
    Join Date
    Jan 2013
    Posts
    19

    Default

    Well I can't see it so I can't offer any help. Take some good pics and maybe.

Page 6 of 6 FirstFirst ... 456

Similar Threads

  1. Radio dead after telephone removal / OBC PPPP Code
    By 632 Regal in forum 5 Series BMW
    Replies: 14
    Last Post: 03-20-2018, 10:40 PM
  2. No sound from Radio
    By caf2461 in forum 5 Series BMW
    Replies: 5
    Last Post: 09-10-2012, 07:40 PM
  3. Radio turns on, but no sound?
    By rcbrown23 in forum 5 Series BMW
    Replies: 12
    Last Post: 08-21-2007, 04:29 PM
  4. OEM radio has power, no sound...
    By 91bmw525i in forum 5 Series BMW
    Replies: 22
    Last Post: 03-03-2005, 02:06 PM
  5. factory radio is dead...what works with the changer?
    By RIPN RAY in forum 5 Series BMW
    Replies: 10
    Last Post: 12-30-2004, 12:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •