Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: e32 735i '91 engine starts, sputters, revs up + down between 1000 + 2000 RPM - solved

  1. #11
    Join Date
    Jan 2007
    Location
    Dayton Ohio
    Posts
    1,462

    Default

    Actually made and installed two, one for the original and one so I will never have that problem again.

  2. #12
    Join Date
    May 2004
    Location
    Japan
    Posts
    8,960

    Default

    Recently I also read about some cases where the EML control module failed. Engine did not start, another case the EML light did not go out = ran in limp mode, another case engine could not rev to max.

  3. #13
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,284

    Default

    That sounds pretty comprehensive, hard too argue.

    However I wouldn't be too keen about passing carb and brake cleaner through that little valve, I'm pretty sure it would have a small butyl rubber seal which would not take kindly to that harsh a clean. Even WD40 overnight...

    I remember troubleshooting mine once, after installing a new charcoal cannister I wanted to verify it was ok. I figured that closed one way (NC) without power in direction of the arrow was normal, and that with power it opened so test was good. It was for sure the original valve from factory on a euro 10/88 M30B35. Oh, and it was running 100%, no idle hunt.

    Have you tried disconnecting the ICV, O2 sensor and the AFM? If it idles ok missing one, perhaps that is the culprit? Is the ICV working nice, smooth and free? Is the TPS clicking closed when @idle? (Not sure how this translates to a EML/fly by wire setup, or whether it has a TPS or some other feature.
    Last edited by genphreak; 10-02-2017 at 12:47 AM.

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

Page 2 of 2 FirstFirst 12

Similar Threads

  1. 1991 e32 735i pan gasket replacement m30 engine
    By Kibokojoe in forum 5 Series BMW
    Replies: 11
    Last Post: 03-02-2016, 05:51 AM
  2. Need an M30 engine for my sons 735i
    By Kibokojoe in forum 5 Series BMW
    Replies: 1
    Last Post: 08-16-2012, 10:27 PM
  3. Stupid engine problem solved...
    By Sidney Rough-Diamond in forum 5 Series BMW
    Replies: 8
    Last Post: 06-03-2007, 12:18 PM
  4. Occasional 525i M50 Engine Misfire Problem – Solved
    By stilljester in forum 5 Series BMW
    Replies: 3
    Last Post: 01-20-2007, 11:11 PM
  5. Couple of related questions on M50 engine revs
    By ktteoh in forum 5 Series BMW
    Replies: 0
    Last Post: 12-06-2005, 06:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •