Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: '95 525iT, no crank, no start, no power windows, sunroof or doorlocks,

  1. #1
    Join Date
    Jan 2005
    Posts
    107

    Default '95 525iT, no crank, no start, no power windows, sunroof or doorlocks,

    I've been away from this site for a long time, but I'm back with a 1995 525iT. I'm having a bunch of electrical problems.

    When trying to start the car, I get full dash lights, but no action from the starter. I have no power windows, sunroof, radio, or door locks. the wipers only work on high speed and don't park. The horn blows, headlights work, and cabin air blower works on all speeds.


    Battery was going dead overnight.
    Found broken 3rd brake light wires
    Found broken rear window heater wires.
    Found faulty micro-switch at rear window lock, failed closed (making relay module click repeatedly)
    Measured 3.5+/- amp draw on battery even with the above repaired
    The RH tailgate wiring harness at tailgate is good, but I haven't cut the loom to check the LH tailgate harness.
    BOTH fusible links are fine
    All fuses are fine

    I don't know yet where the current draw is coming from. I still have to pull fuses to check.

    Any and all ideas and advise would sure be appreciated.

    Chris

  2. #2
    Join Date
    Jan 2005
    Posts
    107

    Default

    update.

    Correction...The current draw is 2.5 amps NOT 3.5.

    I pulled all fuses, the relay module and the general module. No change in current draw. (not sure how that is possible)
    I cut the LH tailgate wiring loom to inspect the wires. They were all perfect.

    Need help.

    Thanks
    Chris

  3. #3
    Join Date
    Jan 2005
    Posts
    107

    Default

    I think I found the center of the electrical universe as for as the gremlins I'm having are concerned.

    I have NO power at the starter terminal 50 with key in start position. I check power at the ignition switch. Got battery voltage at big red wire. I even have battery voltage at the black/yellow wire with key in start position. That black/yellow wire changes to black/green at big connector under dash and continues to the electric immobilizer control module (starter relay) located behind the LH kick panel speaker.

    The wiring diagrams show the output of the starter relay to starter terminal 50 to be black/yellow. I HAVE NO power at the output of the relay.

    I removed the relay and jumped between the two wires at the relay connector. FIRE IN THE HOLE!!!!

    Now to order a new relay and hope all else is well in my (car's) electrical universe.

  4. #4
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,711

    Default

    I wish I could add something to help, but your updates sound like your going in the right direction. relay a probability, the voltage drain I have no clue about. Did you check the 2 main fuses from the battery? I think the roof, windows and locks are on the same line.
    95 E34 530I V2.34
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  5. #5
    Join Date
    Jan 2005
    Posts
    107

    Default

    yep, both fuse links near the battery are good. I checked visually and with a multimeter.
    There are 9 terminals on the electronic immobilizer control relay (starter relay) I cant find any reference as to what all the terminals are for. I only found the two wires for the starter circuit. Hopefully the other wires send signals to fix my other issues.

  6. #6
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,711

    Default

    Sounds like the immobilizer is in theft mode, if new relay don't work then it is most likely the theft unit. Took me 6 months to figure it out on the 850 intermittent then no start issue. Figured the 1 wire and cut it, the whole world was good again.
    95 E34 530I V2.34
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  7. #7
    Join Date
    Jan 2005
    Posts
    107

    Default

    632Regal Thanks, where/what is the immobilizer unit, and what wire did you cut?

  8. #8
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,711

    Default

    Quote Originally Posted by duckloads View Post
    632Regal Thanks, where/what is the immobilizer unit, and what wire did you cut?
    Hahaha... let me look
    95 E34 530I V2.34
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  9. #9
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,711

    Default

    It's at the end but a worthy read for the 6 months of issue. I would not recommend just cutting a wire without finding out which one it is supposed to be on your year/model. Good luck and many well wishes my friend.

    http://www.bimmernut.com/forum/showt...ht=immobilizer
    95 E34 530I V2.34
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  10. #10
    Join Date
    Jan 2005
    Posts
    107

    Default

    well Mr. Regal, I am impressed and even envious in your level of (in)sanity. I've always wanted an 8 Series, because of their beauty, but I've not gotten to (or past) the level of mental maturity for that, yet.

    I have owned a couple of e38 7series, and they nearly broke me.

    thanks for the read.

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Got An E36 That Won't Crank/Start?
    By shogun in forum 3 Series BMW
    Replies: 1
    Last Post: 08-03-2009, 11:14 PM
  2. Sunroof Motor 525iT
    By DavidPorter in forum 5 Series BMW
    Replies: 0
    Last Post: 03-09-2008, 07:45 PM
  3. If you have a 525iT and have sunroof issues....
    By shrike071 in forum 5 Series BMW
    Replies: 1
    Last Post: 11-29-2006, 02:01 PM
  4. Sunroof and Windows always on
    By BillionPa in forum 5 Series BMW
    Replies: 7
    Last Post: 08-15-2006, 07:28 AM
  5. Replies: 8
    Last Post: 07-12-2004, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •