Results 1 to 10 of 10

Thread: E34 A/C Strange problem/Cabin filter??

  1. #1
    Join Date
    Oct 2012
    Location
    Isle-of-Lewis, Scotland
    Posts
    15

    Default E34 A/C Strange problem/Cabin filter??

    Hi Guys,
    I have just MOT,ed my 95 520i and I am dead chuffed with it after a full respray,new wheels,new suspension parts etc etc (i could go on) I have owned the car for nearly 14 years and to this day it IS my car of choice.

    I desperately need your help, I have a very healthy a/c ON IT APART FROM 1 NIGGLING PROBLEM! When I sart the car from cold the a/c will work all day non stop but if I stop the engine for any reason ie at a Filling Station the heater comes on and the a/c goes of, it will not come on again until the engine cools down which is very frustrating, common thing here is the engine temp something is switching of my a/c when it senses that the engine temp is at running temp, but what??

    Cabin filter?? is there one fitted to my car? and if so how do I get to it?

    Thanks,
    John

  2. #2
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,095

    Default

    I assume your problem is not the cabin filter, that is maybe a problem of the control panel or the IHKA control module behind the center console.
    As you talk about MOT, you are probably from the U.K. and that means right hand drive, that makes it a bit more complicated to replace the cabin filter, as the steering column is in the way. U.K. car spec cabin filters are special, here you can see how it is replaced on a E32, basically same procedure on the E34 http://www.meeknet.co.uk/E32/Microfilter/Index.htm
    A 1995 model has a cabin filter.

    Here is the pinout of the IHKA control module for a left hand drive car, so when I say driver side in that link, on your car it is passenger side http://www.bimmerboard.com/forums/posts/648300/
    http://www.bimmerboard.com/forums/posts/427753/
    http://www.bimmerboard.com/forums/posts/426626/
    resolder the IHKA control module http://www.bimmerboard.com/forums/posts/400077/
    http://www.bimmerboard.com/forums/posts/220273/

  3. #3
    Join Date
    Oct 2012
    Location
    Isle-of-Lewis, Scotland
    Posts
    15

    Default Thanks

    Quote Originally Posted by shogun View Post
    I assume your problem is not the cabin filter, that is maybe a problem of the control panel or the IHKA control module behind the center console.
    As you talk about MOT, you are probably from the U.K. and that means right hand drive, that makes it a bit more complicated to replace the cabin filter, as the steering column is in the way. U.K. car spec cabin filters are special, here you can see how it is replaced on a E32, basically same procedure on the E34 http://www.meeknet.co.uk/E32/Microfilter/Index.htm
    A 1995 model has a cabin filter.

    Here is the pinout of the IHKA control module for a left hand drive car, so when I say driver side in that link, on your car it is passenger side http://www.bimmerboard.com/forums/posts/648300/
    http://www.bimmerboard.com/forums/posts/427753/
    http://www.bimmerboard.com/forums/posts/426626/
    resolder the IHKA control module http://www.bimmerboard.com/forums/posts/400077/
    http://www.bimmerboard.com/forums/posts/220273/

    Thanks Shogun,that gives me someting to go on

  4. #4
    Join Date
    Feb 2006
    Location
    Oldham, England
    Posts
    3,076

    Default

    Is your aux fan coming on with the AC? If not, the AC system will be fighting a losing battle.
    Oct '00 E46 330i. Feb '92 525i (departed)

  5. #5
    Join Date
    Oct 2012
    Location
    Isle-of-Lewis, Scotland
    Posts
    15

    Default E34 a/c

    Hi,
    yes my Aux fan works and is brand new and the A/c will work perfectly all day as long as I dont switch the engine off.
    Thanks for the reply

  6. #6
    Join Date
    Feb 2006
    Location
    Oldham, England
    Posts
    3,076

    Default

    When you say that the heater comes on, do you mean that the system blows hot air when you have selected cold? IIRC, the default position for the heater valves is open.
    Oct '00 E46 330i. Feb '92 525i (departed)

  7. #7
    Join Date
    Oct 2012
    Location
    Isle-of-Lewis, Scotland
    Posts
    15

    Default E34 A/C Strange problem/Cabin filter??

    Yes, thats what happens but only if I switch the car off and restart it

  8. #8
    Join Date
    Feb 2006
    Location
    Oldham, England
    Posts
    3,076

    Default

    On my old E34, you could have both heat and AC on - it was good for demisting. So they are not mutually exclusive. Perhaps confirm that the heating works correctly without the involvement of AC and proceed from there?
    Oct '00 E46 330i. Feb '92 525i (departed)

  9. #9
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,325

    Default

    Absolutely you have to check the heater valves are:

    - opening and closing properly
    - sealing properly

    It can be the valves are old and worn inside, clogged or jammed from plaque and/or corrosion. When you shut down, they are hot and they won't close perhaps, or the something electronic is not closing them. Big question here is whether the problem is electrical / to do with the IHKA controls or the IHKA itself. Verifying what is or is not happening is what you need to do, E.g.

    When the problem occurs;

    1. is the re-window demister making the rear window warm? It takes a good 5 minutes to do so, so check carefully. Also, is the demister light on or off?
    2. Does the AC compressor cycle normally? Understand that AC being on does not mean that the air will blow colder through the vents, it just means that the air is first cooled and dried, then runs through the heater and the right amount of heat transferred to it (to increase, maintain or reduce the set cabin temperature.
    3. Is the auxilary fan in front of the radiator running at full speed?
    4. Does it happen on both sides of the cabin at the same time?
    5. Is the air blindingly hot or does it take a few minutes to blow like a Saharan scirocco?

    A good thing to do is find someone with a diagnostic system that works with older Bimmers (pre-OBD2) and look for any reports of stepper motor and other IHKA errors.

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

  10. #10
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,095

    Default

    Is this problem meanwhile solved? How?
    Maybe you disassemble the IHKR control module and clean it and look for cold solderings.
    There is something on my website, see resoldering IHKA, scroll down here to see the pics http://twrite.org/shogunnew/fixes/climate.html

Similar Threads

  1. 91 525i E34 Cabin Air Filter
    By zedtech2000 in forum 5 Series BMW
    Replies: 10
    Last Post: 09-06-2011, 04:40 PM
  2. Cabin Filter
    By vping in forum 5 Series BMW
    Replies: 4
    Last Post: 01-31-2010, 09:21 PM
  3. Two piece cabin filter
    By ss2115 in forum 5 Series BMW
    Replies: 3
    Last Post: 01-31-2010, 06:18 AM
  4. Microfilter or Cabin filter?
    By ska-texas in forum 5 Series BMW
    Replies: 20
    Last Post: 08-17-2006, 12:54 PM
  5. cabin filter
    By cmb in forum 5 Series BMW
    Replies: 2
    Last Post: 03-02-2004, 11:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •