Results 1 to 2 of 2

Thread: Really bad idle after leaving the battery disconnected?

  1. #1

    Default Really bad idle after leaving the battery disconnected?

    I disconnected the battery while I was taking the interior out, hooked it back up a couple of times just so I could lock up the car.

    Installed a new air filter today, started up the car and it has a really bad idle when it did not have any issues before. I checked all connections to the airbox but what else should I check?

    When I blip the throttle the response is horrible, in fact the car almost wants to stall if I open up the throttles too fast.

  2. #2

    Default

    I removed the intake, checked the elbow for cracks, put it all back together, hooked it up, started the car and now it idles fine.

    So not sure exactly what I did to fix the problem but it allowed me to balance the throttle bodies as planned.

Similar Threads

  1. Battery voltage specs at idle?
    By Russell in forum 5 Series BMW
    Replies: 12
    Last Post: 01-15-2009, 11:44 PM
  2. is my ihkr disconnected?
    By 525i winter driver in forum 5 Series BMW
    Replies: 0
    Last Post: 06-29-2008, 01:56 PM
  3. Disconnected battery for one hour, now E34 wont start
    By Murphy211 in forum 5 Series BMW
    Replies: 5
    Last Post: 06-01-2008, 09:23 AM
  4. rough idle 89 525 after disconecting battery
    By ron56 in forum 5 Series BMW
    Replies: 4
    Last Post: 10-31-2004, 11:09 PM
  5. Disconnected pipe
    By biondani in forum 5 Series BMW
    Replies: 2
    Last Post: 06-06-2004, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •