Results 1 to 5 of 5

Thread: IDLE PROBLEM, please help!!

  1. #1
    Join Date
    Aug 2011
    Location
    Naples, Fl
    Posts
    35

    Default IDLE PROBLEM, please help!!

    ill add pictures if requested*my e34 (m20) has an idle problem and misfire. the car was running great till about this week. last week it wasn't running due to a slave cylinder failure. I replaced that and got the clutch working. at first the car wouldn't start and after having a BMW specialist diagnose it and removing/testing the fuel pump, he swapped the fuel relay with another similar(blue) relay under the hood. the specialist told me I had a bad fp relay. after the car got started, it idled fine. but then it would jump to 2k or 2500 and just stay there. *when the idle goes back to normal (700-900) the check engine light comes on. when the revs increase, the check engine light goes off. when driving; it takes off from 1st pretty rough and jumps. in any other gear if I go wide open throttle it stutters, especially in 5th. sometimes it will even completely just shut down.*what I think: I'm not looking at any vacuum leaks but there are a few things I'll point out. there are 2 in/outlets (not sure) that are to the left of the tb. they look like they would have hoses attached to them but don't have any.*when the tech was working on my car and the idle climbed, he tapped on the ICV and it started to idle normal.*my car tells me: the oil level sensor*there are 2 plugs. one on each side with orange housing that I can't seem to find where they go or are for.*there's a plug right above the alternator that isn't connected?(possible oil level sensor?)*I'm trying to get help and figure out the idle problem and why it randomly shut down.*and I also recently discovered my car has Bosch platinum 4+ spark plugs.*

  2. #2
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,331

    Default

    Those plugs can be a problem.

    ICV will need a clean as it an cause all sorts of drivability trouble as you describe.

    Not looking for leaks? IMH experience, one looks for vacuum leaks long and hard, or spends a long time working on non trivial, non root cause issues

    Use a fuel pressure gauge to check you have 43.5 PSI.

    Stick the car on diagnostics to 'know what it thinks of itself'. Those plugs could be causing lots of weirdness... but the old vacuum pipes connectors and even sensors are the most likely trouble. Check the oil level connector is properly connected but this is a common fault nothing to do with drivability.

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

  3. #3
    Join Date
    Aug 2011
    Location
    Naples, Fl
    Posts
    35

    Default

    where could the possible vacuum leaks be? and i think the problem is fuel delivery. i removed my fuel pump a week ago and ran it on a bettery, it seemed to run fine. but once it's back in the car and it's cranking, it makes some weird sounds as it's running. it sounds as if it's running kind of rough and when i stop cranking it, it cuts off pretty rough. possible fuel pump replacement?

  4. #4
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,331

    Default

    Sure. Try running it manually (ensure **zero** risk of sparking contacts mind you!) and turning on/off. Did you check the FPR- manifold line btw?

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

  5. #5
    Join Date
    Sep 2007
    Location
    Michigan
    Posts
    335

    Default

    Your fuel pump may run and deliver fuel as observed but unless you get the right psi you will have problems as you described.

    1990 535im 421,000 miles, 1987 325is, 1989 325is, 1990 m3, 1991 318is, 2001 X5 3.0

Similar Threads

  1. E34 535 Idle problem
    By Panda in forum 5 Series BMW
    Replies: 8
    Last Post: 06-23-2006, 07:05 AM
  2. E34 idle problem
    By erubin in forum 5 Series BMW
    Replies: 8
    Last Post: 09-08-2005, 08:49 AM
  3. idle problem?
    By liquidtiger720 in forum 5 Series BMW
    Replies: 3
    Last Post: 07-10-2005, 12:51 PM
  4. E34 Idle problem need help!!!!!
    By daniel092284 in forum 5 Series BMW
    Replies: 1
    Last Post: 02-15-2005, 02:46 AM
  5. Idle Problem
    By Geoff Hoad in forum 3 Series BMW
    Replies: 1
    Last Post: 06-04-2004, 09:52 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •