Results 1 to 5 of 5

Thread: Shuttering when stopping...

  1. #1
    Join Date
    May 2008
    Location
    Enumclaw, WA
    Posts
    103

    Default Shuttering when stopping...

    I did my brakes about 4 months ago, then the car sat. I started driving it again last month and noticed that it shutters when I come to a stop. Not really having anytime with a fresh new baby I have kind of let it go for a while, but its now getting worse. I also can't remember if it shuttered before I did the brakes or not. I didn't turn my rotors....could that be the source of my problem?

    Dan

    Captain Dan
    1995 530i
    1977 530i

  2. #2
    Join Date
    Dec 2004
    Location
    Sydney, Australia
    Posts
    4,353

    Default

    on the e34?
    1 Is it only when stopping under brakes?
    2 Did you replace the rotors? Whish kind?
    3 Did you bed them in?
    If yes to the above, they may still be glazed- you have to inspect them. Could also be a loose pad/s/locator spring/s.

    I use new rotors and pads every time- and use Akebono ceramics, costly, but no probs ever. One day when my brakes again save my/someone else's life, I'll be glad about that

    Join the Aussie
    540i LE yahoo forum

    08/88 535i e34 M30+miller MAF, 'stiens, tints & teeth!

  3. #3
    Join Date
    May 2004
    Location
    Sydney, Australia
    Posts
    2,699

    Default

    yeah, if you replace the pads but dont turn the rotors or replace them, you will feel shuddering.

  4. #4
    Join Date
    May 2008
    Location
    Enumclaw, WA
    Posts
    103

    Default Updates

    Well heres an interesting stuff I found while testing this week. The shuttering is real light to non existant when in Neutral, and it only happens, right before you stop, which is also when you get a dip in RPMs. Lately my power steering seems very sluggish, and the car seems to struggle hard if you move it back and forth fast while at idle. I am going to rule out brakes, they seems to work flawlessly at anyother speed and direction, I think I am having some driveline I issues or something connected to the motor. Could this be a sign of a dying power steering pump or alternator?
    Dan

    Captain Dan
    1995 530i
    1977 530i

  5. #5
    Join Date
    Dec 2003
    Location
    Minneapolis, MN
    Posts
    574

    Default

    Does the stuttering still happen once the temp gauge shows that the engine is all the way warm? Does the stuttering happen if you use the parking brake to stop instead?

    If it only happens when the power brakes are used to bring the car to a halt, I would guess that there might be a vacuum leak at the or inside the brake booster.
    I would also guess that it's the Idle control valve that's dirty and sluggish.
    Or (like you said) a bad pump or alternator could be putting extra strain on the engine. I know the bearings on my alternator have been getting louder and louder and I also see the engine struggle momentarily if I move the PS pump back and forth quickly. Swapping out PS fluid, PS hoses, and reservoir made a slight difference, but I think once I get around to replacing the alt, everything will spin with less resistance.


    1995 525i 5-Speed 201,000mi

Similar Threads

  1. M30 dies when stopping periodically
    By Asamaan in forum 5 Series BMW
    Replies: 29
    Last Post: 05-07-2010, 01:42 PM
  2. ot: not speeding and not stopping
    By timandbim in forum 5 Series BMW
    Replies: 5
    Last Post: 10-16-2007, 01:04 PM
  3. My speedo stopping working?
    By pundit in forum 5 Series BMW
    Replies: 8
    Last Post: 08-19-2006, 12:17 AM
  4. Shuttering
    By Bimmer93 in forum 5 Series BMW
    Replies: 7
    Last Post: 02-18-2006, 02:31 PM
  5. 328is stalling when stopping..PLEASE HELP!
    By bmwfreq in forum 3 Series BMW
    Replies: 1
    Last Post: 01-12-2006, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •