Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Capacitors in a 92 e34 Cluster (blue cluster)

  1. #1
    Join Date
    Nov 2005
    Location
    Montreal
    Posts
    857

    Default Capacitors in a 92 e34 Cluster (blue cluster)

    Well, I've opened the cluster once again, since I'm getting faulty messages telling me the oil is low, and the gas is empty when there's still well over 20 liters (25%), and since I've been meaning to do it for a long time, it's time to replace the capacitors.

    They are :
    1000F 16V
    220F 16V
    4.7F 63V
    (63V?? An odd number in my book, all puns aside)

    Next step: reassemble the cluster again, put it back in the car, drive to go get the capacitors Saturday (the specialty store closes too early for me to get there in time during the week).

  2. #2
    Join Date
    Nov 2005
    Location
    Montreal
    Posts
    857

    Default

    Done deal, replaced with:

    1000 F 100V, a bit of a tight fit
    220F 25V
    4.7F axial 80V ; it works all the same, I just bent the lead downwards to make it stand upright as a radial capacitor.

  3. #3
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,127

    Default

    and all the faulty messages gone now?

  4. #4
    Join Date
    Oct 2004
    Location
    Honolulu
    Posts
    3,105

    Default

    I found all the capacitors in 105 degree and in the needed values at Digikey.

    Shipped for under $10


    Vee ave vays of dealing vid your kind...........

  5. #5
    Join Date
    Nov 2005
    Location
    Montreal
    Posts
    857

    Default

    Quote Originally Posted by shogun View Post
    and all the faulty messages gone now?
    So far, yes. I'll see about my fuel gauge, which usually drops to empty at about 1/3 full. Another project to be proud of!

  6. #6
    Join Date
    Aug 2008
    Posts
    879

    Default

    Quote Originally Posted by BMWDriver View Post
    So far, yes. I'll see about my fuel gauge...
    So did it fix the fuel gauge? I want to fix mine.

  7. #7
    Join Date
    May 2004
    Location
    Japan
    Posts
    9,127

    Default

    fuel gauge might be a problem inside the tank, check the float and measure the 2 wires of the float
    http://bmwe32.masscom.net/maxf_website/gauge.htm
    "Check the 2 fine wires are complete and soldered to their mountings. Mine were; if one of your wires is broken, it is not normal wire - it's "resistance wire" what you can get from electronics stores - problem with that is that resistance wire comes in different "strengths" (ohms/meter). Try taking a sample of a broken wire into a really good electronics hobby shop, or try for a replacement sensor. "


    http://bmwe32.masscom.net/johan/fuel...el_sender.html

  8. #8
    Join Date
    Aug 2008
    Posts
    879

    Default

    Quote Originally Posted by shogun View Post
    fuel gauge might be a problem inside the tank...
    In my case I get a good reading on the obc so I assume the fuel level sender is working - it's just the fuel gauge in the cluster that is wonky.

  9. #9
    Join Date
    Mar 2005
    Location
    TORONTO
    Posts
    3,011

    Default

    Darn. You didn't need to buy my reman clusterboard eh? Always satisfying to fix things yourself!
    :: HIDCanada.com | Illuminating Your World


  10. #10
    Join Date
    Aug 2008
    Posts
    879

    Default

    Quote Originally Posted by Qube View Post
    Darn. You didn't need to buy my reman clusterboard eh? Always satisfying to fix things yourself!
    I don't think it's the kind I need - yours might fix my fuel gauge problem but I don't really care about that since the obc works . I am coming up on 29960km and want to swap it for a blue-backed one that I have which is almost mostly working in my car now.

Page 1 of 2 12 LastLast

Similar Threads

  1. Gauge cluster capacitors
    By russiankid in forum 5 Series BMW
    Replies: 5
    Last Post: 11-24-2008, 01:23 AM
  2. Blue or White Instrument Cluster Backs?
    By Panzer Captain in forum 5 Series BMW
    Replies: 2
    Last Post: 10-09-2007, 08:41 PM
  3. Dash cluster capacitors need help part no.
    By takumidrift30 in forum 5 Series BMW
    Replies: 4
    Last Post: 09-13-2006, 05:03 PM
  4. blue plasma cluster ilumination
    By shogun in forum 5 Series BMW
    Replies: 10
    Last Post: 07-27-2005, 12:30 AM
  5. Capacitors in a '95 Cluster...dif than E34.net
    By Aaron Bakos in forum 5 Series BMW
    Replies: 4
    Last Post: 01-11-2005, 08:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •