Results 1 to 5 of 5

Thread: Instrument Cluster

  1. #1
    Join Date
    Jun 2004
    Location
    Southampton, UK
    Posts
    51

    Default Instrument Cluster

    I have a 91 525i. Neither of the buttons on the instrument cluster, odometer reset and OBC one, work. Everything else seems to be in working order though now that I have put the washer sensor up the right way ;-)

    Anyone got any idea what could be causing this and is there an easy fix?

    Thanks
    Ian

  2. #2
    Join Date
    Jan 2004
    Location
    Benneton (United Colors of)
    Posts
    3,067

    Default

    consider going to www.bmwe34.net and seeing what repair procedures that site has that apply to the broken things on your particular car. sounds like you have capacitor failures on the instrument cluster, the fix for this is detailed there.

    Quote Originally Posted by biondani
    I have a 91 525i. Neither of the buttons on the instrument cluster, odometer reset and OBC one, work. Everything else seems to be in working order though now that I have put the washer sensor up the right way ;-)

    Anyone got any idea what could be causing this and is there an easy fix?

    Thanks
    Ian
    "..Torchinski v. Peterson that it is legal to carry a concealed weapon, so long the weapon is totally slick like a huge ass machine gun that you carry under a trench coat, like in the Matrix."


  3. #3
    Join Date
    Jun 2004
    Location
    Southampton, UK
    Posts
    51

    Default

    Quote Originally Posted by ryan roopnarine
    consider going to www.bmwe34.net and seeing what repair procedures that site has that apply to the broken things on your particular car. sounds like you have capacitor failures on the instrument cluster, the fix for this is detailed there.
    Thanks, I did visit there but somehow missed that one :-(

    Sounds like it will be the problem though as the bulb on the fuel guage is chaotic to say the least. Oh well, off to Maplin I must go to get some capacitors and a new reel of solder...

    Thanks
    Ian

  4. #4
    Join Date
    Jan 2004
    Location
    Benneton (United Colors of)
    Posts
    3,067

    Default

    Quote Originally Posted by biondani
    Thanks, I did visit there but somehow missed that one :-(

    Sounds like it will be the problem though as the bulb on the fuel guage is chaotic to say the least. Oh well, off to Maplin I must go to get some capacitors and a new reel of solder...

    Thanks
    Ian

    http://www.bmwe34.net/e34main/mainte...capacitors.htm
    "..Torchinski v. Peterson that it is legal to carry a concealed weapon, so long the weapon is totally slick like a huge ass machine gun that you carry under a trench coat, like in the Matrix."


  5. #5
    Join Date
    Jun 2004
    Location
    Southampton, UK
    Posts
    51

    Default

    Quote Originally Posted by ryan roopnarine
    Saw it the second time, I blame it on the alcohol tonight :-)

    Does anyone have a list of the values of the capacitors to save me opening it to find them out, reassembling to drive to the shops before dismantling again :-( Might as well replace all 5 once I've got the thing open. Time to dig out the Bentley to get the removal instructions...

    Ian

Similar Threads

  1. instrument cluster
    By Fraz06 in forum 5 Series BMW
    Replies: 5
    Last Post: 06-23-2007, 02:53 AM
  2. instrument cluster
    By Mendozart in forum 5 Series BMW
    Replies: 7
    Last Post: 08-25-2006, 09:37 PM
  3. Help - Have the instrument cluster out.....
    By western99 in forum 5 Series BMW
    Replies: 5
    Last Post: 11-22-2004, 10:32 PM
  4. Instrument Cluster
    By netmgr in forum 5 Series BMW
    Replies: 1
    Last Post: 11-22-2004, 09:39 PM
  5. Instrument cluster
    By baileydog in forum 5 Series BMW
    Replies: 2
    Last Post: 10-07-2004, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •