Page 4 of 4 FirstFirst ... 234
Results 31 to 32 of 32

Thread: engine heating once again

  1. #31
    Join Date
    Aug 2004
    Location
    Dubai
    Posts
    834

    Default

    well recently its working better, but seems its not working at all untill the radiator is hot, usually the clutch should go on when u start the engine then goes off. but this one doesn't otherwise its ok. the Aux fan is blowing fueses so it seems to have few coils drawing more current. that means its spinning slower than its supposed to be. I have bypassed the fues to keep it on. but sometimes I find that wire toasted.
    one good change happened is that when I turn off the engine for few minutes and return back to drive I don't find the temp in the high zone. before it was going high.

    I'll keep observing
    Thanks dude ...

  2. #32

    Default

    You didn't mention the year or engine of your car, but I have heard that the e39 model (3-series, ~1992 thru 1998) used a plastic impeller in the factory water pump -- and the impeller would eventually fail due to age or temperature, and basically stop pumping water that would cause over heating.
    I LOVE BC CANADA

Page 4 of 4 FirstFirst ... 234

Similar Threads

  1. Car not heating up enough
    By CrimsonBrian in forum 5 Series BMW
    Replies: 8
    Last Post: 02-21-2011, 06:13 PM
  2. heating problems! Please help!!!!
    By marko in forum 5 Series BMW
    Replies: 3
    Last Post: 02-15-2011, 05:43 PM
  3. 540 v8 over heating
    By dbou in forum 5 Series BMW
    Replies: 4
    Last Post: 08-25-2006, 08:42 AM
  4. A/C stressing engine and heating cabin
    By hoodsstalker in forum 5 Series BMW
    Replies: 3
    Last Post: 06-01-2006, 07:44 PM
  5. Heating Issue
    By e34it in forum 5 Series BMW
    Replies: 12
    Last Post: 03-18-2005, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •