Results 1 to 8 of 8

Thread: Does your passenger heat control click at full cold or warm?

  1. #1
    Join Date
    Jan 2004
    Location
    Fogtown
    Posts
    656

    Default Does your passenger heat control click at full cold or warm?

    I am still trying to get my passenger heat to work. I just noticed that my driver's heat control clicks when you move it all the way to cold or all the way to warm(at the end point). The passenger does not however.

    So far I replaced the heater valve and verified that my aux water pump works.

  2. #2
    Join Date
    Dec 2003
    Location
    Los Angeles, CA
    Posts
    206

    Default

    i have that same thing.
    driver clicks, passenger doesn't.
    i thought mine was broken. maybe not?

  3. #3
    Join Date
    Jan 2004
    Posts
    348

    Default Only the driver's side "clicks"

    It is the "full" setting and will also override the passenger side setting when clicked on to full.

    Quote Originally Posted by Anton CH.
    I am still trying to get my passenger heat to work. I just noticed that my driver's heat control clicks when you move it all the way to cold or all the way to warm(at the end point). The passenger does not however.

    So far I replaced the heater valve and verified that my aux water pump works.

  4. #4
    Join Date
    Jan 2004
    Location
    Fogtown
    Posts
    656

    Default

    Hmm, maybe thats there is only passenger heat when driver is on full.

  5. #5
    Join Date
    Jan 2004
    Location
    Fogtown
    Posts
    656

    Default

    Okay, is the driver clicked cold supposed to override passenger heat settings as well?

  6. #6
    Join Date
    Dec 2003
    Location
    Wellington,New Zealand
    Posts
    3,868

    Default yes nt

    nt
    Gone but not forgotten

  7. #7
    Join Date
    Jan 2004
    Location
    Fogtown
    Posts
    656

    Default

    Well I just wasted $140, time, and bruised knuckles. Glad I found out how to use it before I took the whole control center apart.

  8. #8
    Join Date
    Jan 2004
    Location
    Lexington, Kentucky
    Posts
    2,561

    Default Your manual explains how the heater controls work

    Not sure but the Bentley manual may explain as well.

    Quote Originally Posted by Anton CH.
    I am still trying to get my passenger heat to work. I just noticed that my driver's heat control clicks when you move it all the way to cold or all the way to warm(at the end point). The passenger does not however.

    So far I replaced the heater valve and verified that my aux water pump works.
    Thanks,

    1995 525i Auto, M50TU 2.5L, EAT chip, 1/95 build, USA, 205/65/15 tires, ASC+T, HID, lumbar, EC Mirror, BMW Alpine 5 radio with BMW-Pioneer CD Changer, abt 236k miles, Oxford Green/Parchment

Similar Threads

  1. No Passenger heat
    By vping in forum 5 Series BMW
    Replies: 10
    Last Post: 01-06-2009, 04:51 PM
  2. No floor heat on passenger side
    By Kibokojoe in forum 5 Series BMW
    Replies: 1
    Last Post: 11-02-2008, 09:37 PM
  3. Replies: 4
    Last Post: 08-21-2006, 04:36 AM
  4. Runs fine when cold! But dies when getting warm! 735i e32
    By Unregistered in forum 5 Series BMW
    Replies: 19
    Last Post: 03-28-2004, 10:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •