Results 1 to 10 of 10

Thread: Stomp test worked (finally!) - how do I clear codes?

  1. #1
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default Stomp test worked (finally!) - how do I clear codes?

    Bentley / website say to wait for a 1000 code, then hold down the accelerator for 10 seconds. I never get that; it just keeps cycling through 1221 (O2 sensor). I'd like to clear the codes and see if it throws again. Advice?
    1995 525iM - 131k - Alternator play, broken s-belt
    1995 525iA - 147k - Tensioner weirdness, broken s-belt
    2001 Intgra GS-R - 130k - spun bearing
    2002 Honda Odyssey - 80k - fragged transmission

  2. #2
    Join Date
    Dec 2003
    Location
    PA
    Posts
    5,403

    Default

    Disconnect battery, drive. Hope you fixed your ****

  3. #3
    Join Date
    Jul 2006
    Location
    Victoria, Australia
    Posts
    164

    Default

    What did you have to do to get your stomp-test to work? I'm having troubles with my 95 525i.

    Thanks

    Old car: 95 525i, OB/Silver, Eibachs, Style 66, Missed dearly!!
    VIN Decoder | Online ETK
    | E34 Bible

  4. #4
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default

    Start stomping instantly, and rapid-fire - picture it like this:

    Step 1 - Insert key
    Step 2 - Turn key to "on" positionSTOMPSTOMPSTOMPSTOMPSTOMP.

    Works a treat.
    1995 525iM - 131k - Alternator play, broken s-belt
    1995 525iA - 147k - Tensioner weirdness, broken s-belt
    2001 Intgra GS-R - 130k - spun bearing
    2002 Honda Odyssey - 80k - fragged transmission

  5. #5
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default

    Hmmm. Proposal on how to start the car once the battery is disconnected?


    I kid, I kid. Will disconnecting the battery and letting it sit clear the codes (as well as all my other useful stuff like radio presets, clock, etc?)
    1995 525iM - 131k - Alternator play, broken s-belt
    1995 525iA - 147k - Tensioner weirdness, broken s-belt
    2001 Intgra GS-R - 130k - spun bearing
    2002 Honda Odyssey - 80k - fragged transmission

  6. #6
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,694

    Default

    you could just disconnect the ECU for a few minutes and you wont lose the radio code.
    95 E34 530I V2.31
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  7. #7
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default You da man. I'll try that tonight. Thanks! [nt]

    <nt>

  8. #8
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default

    Quote Originally Posted by 632 Regal
    you could just disconnect the ECU for a few minutes and you wont lose the radio code.
    So, uh, I figured that I'd knock this out with my trusty Bentley and can't freaking find it. Bleh. So, uh, how does one disconnect the ol' ECU? Thanks in advance.
    1995 525iM - 131k - Alternator play, broken s-belt
    1995 525iA - 147k - Tensioner weirdness, broken s-belt
    2001 Intgra GS-R - 130k - spun bearing
    2002 Honda Odyssey - 80k - fragged transmission

  9. #9
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,694

    Default

    pop the hood, remove the ECU cover on the left hand side by the firewall....disconnect the ecy connector. I dont know which one is the ECU on the 525 or 535 but you could pop them all off for about 10-30 seconds and pop them on with no adverse results. Might be a good thing to reset all of them anyways.

    Quote Originally Posted by ProZak
    So, uh, I figured that I'd knock this out with my trusty Bentley and can't freaking find it. Bleh. So, uh, how does one disconnect the ol' ECU? Thanks in advance.
    95 E34 530I V2.31
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  10. #10
    Join Date
    Dec 2005
    Location
    Nashville, TN
    Posts
    180

    Default

    Fabulous, I'll give it a shot and let you know. Thanks!!!
    1995 525iM - 131k - Alternator play, broken s-belt
    1995 525iA - 147k - Tensioner weirdness, broken s-belt
    2001 Intgra GS-R - 130k - spun bearing
    2002 Honda Odyssey - 80k - fragged transmission

Similar Threads

  1. BMW stomp test blink codes fault codes
    By shogun in forum 5 Series BMW
    Replies: 2
    Last Post: 11-12-2009, 10:53 AM
  2. Fault codes w/o stomp test???
    By billkirk in forum 5 Series BMW
    Replies: 1
    Last Post: 10-30-2007, 08:42 AM
  3. stomp test codes for all DME's
    By shogun in forum 5 Series BMW
    Replies: 1
    Last Post: 04-23-2005, 12:59 PM
  4. stomp test codes???
    By johnnyturbo2002 in forum 5 Series BMW
    Replies: 2
    Last Post: 11-22-2004, 09:19 PM
  5. Stomp test for 525i codes
    By bestlawnintown in forum 5 Series BMW
    Replies: 2
    Last Post: 08-18-2004, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •