Results 1 to 2 of 2

Thread: 1994 525i (M50 + 5 Spd) Major hesitation problems.

  1. #1

    Default 1994 525i (M50 + 5 Spd) Major hesitation problems.

    First off, just wanted to thank everyone on the forums. This place has been a great source of information, I'm completely new to BMW's after coming from a long line of Toyota Supras (Must be something about an inline 6

    Just picked up a 94 525i with approximately 134,000 km's on it. Appears to be well maintained and cared for.

    In the past month I've owned the vehicle I've been very impressed, only problem before this was a leaky clutch slave cylinder. Something to expected on a 10 year old car. Solid piece of machincery and with the factory towing package does a great job of moving my race bike.

    The past 3 days I've had alot of problems with hesitation, this only seems to occur on a 'warm' start after the car has been sitting for 2 or 3 hours after the initial drive to work in the morning and sitting in 35 degree C weather. Engine starts normally and acts perfectly but after driving for 4 or 5 minutes the engine refuses to make power, an audible/shaking misfire is heard on multiple cylinders. I can get the engine to rev up but with alot of misfiring and hesitation when the clutch disengaged.
    When I pull off to the side of the road the engine will idle fine and after a minute or two of blipping the throttle the whole situation clears up. This worries me as losing power in a roundabout here in the middle east could end up in a big mess

    No check engine light, checked the codes, pulled all the plugs in good condition and not fouled. I've been keeping the tank full, added some fuel treatment (I doubt condensation is an issue here like back home in eastern Canada) and injector cleaner. Perhaps a failing injector, tps sensor?

    I'm not sure if this is a fuel or a ignition problem. Haven't found an indentical case with an M50 engine in the archives, so any advice would be appreciated before I take it to a dealer.

    Thanks in advance.

    Alfred
    Doha, Qatar.

  2. #2
    Join Date
    Dec 2003
    Location
    Austin, TX
    Posts
    1,181

    Default

    change your plugs, do NOT put in the Bosch platinums or splitfires. As much as i hate it, go to the dealer and buy the stock plugs, they work best in the M50. Also, make sure you are using the highest grade and octane fuel you can find. Mine will sputter if i use crappy fuel. If none of that fixes your problem, have the coils checked, you might have a failing one.
    1995 540iA M-Sport - 76k miles. 1 of 1 auto AW3 cars.
    1995 540i/6 - Misc Parts donor for above.

Similar Threads

  1. 1994 525I Aftermarket CD problems, please help
    By WillDV in forum 5 Series BMW
    Replies: 5
    Last Post: 08-23-2006, 09:16 AM
  2. Major gearbox problems
    By Wyn in forum 5 Series BMW
    Replies: 5
    Last Post: 06-15-2006, 11:23 PM
  3. E34 520i 24v major overheating problems.
    By Bob Gorsuch in forum 5 Series BMW
    Replies: 2
    Last Post: 09-22-2004, 12:50 PM
  4. Replies: 7
    Last Post: 05-20-2004, 09:39 AM
  5. 1994 525i Clutch Problems
    By Charles in forum 5 Series BMW
    Replies: 9
    Last Post: 03-19-2004, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •