We have just solved this problem a 850 owner in Japan had for 6 months. I show his comments and our proposals, we suggested and obtained also from German and US boards:

1991 850Ci VIN# CB01824
on behalf of a friend in Japan I have a puzzle for you all.

6 months ago
Started well - upon stop, would not restart
No warning messages
Engine cranks, no fuel,
Leave for 1 day - 4 days, restarted ok
While running on the road, no problem
While engine running, Peake tester showed no errors

Recently, longer delay needed to get restart
Now, no start at all
Battery level high, on trickle charger all the time
Peake shows error -- no codes returned
The SEM indicator does not light up and switching between SEM makes no change
BUT, cranking for about 10-12 seconds brings up the SEM indicator light - can switch between SEM 1 or 2 times then SEM indicator light disappears.

Owner has swapped the following modules

GM2 general module2
EGS transmission controller
LKM light control module
Body Unit
Instrument cluster
ABS unit
Motronics controller X2
EML controller
Throttle body x2
Main relay x2
Fuel pump relay x2
O2 sensor relay
DWA anti theft module

Any suggestions?
Does the Antitheft module have its own earthing point?
Much appreciate any suggestions


UK_Mike auf roadfly:
Not sure if youve searched the archives but I had a 'no start' problem that was initially intermittant and then permanent. It was a faulty body control module giving an erroneous 'immobilise' signal to the EML's.
There are a few parallels. I also had problems reading the codes with a scanner. Most of the time I got nothing at all.
The solution was to cut the two immobilising wires to the EML's. I cut them just before the EML plugs in the EML 'black box'. If I remember correctly they were black with a violet stripe. Check the archives.
The car started immediately and ran faultlessly when they were cut.
I initially thought it was a faulty alarm module giving the signal but eventually found it to be the body control module. The alarm signal passes through this module.
Its just an idea and something that is very easy to try out and eliminate. If this isnt the problem, just re-connect the two wires.

I saw your prior post, yes, the parallels are there
the owner swapped the body control module but --
the wiring diagram 6210.0-03 (91-850i) shows SW/VI from the DWA to the body module -- assume that is Swartz (black) and violet
should be an easy check - will pass it on and return with the results -- hopefully good news.
any idea of why that fault was screwing up the diagnostic system?
Schwarz & violet to each EML. I suspect that the immobilise signal may have had some bearing on the diagnostic codes as I have never had a problem since. I suppose, in theory, you could cancel the immobimise signal or maybe turno ff that function through the diagnostic socket and start the engine. Maybe the diagnostics are turned off when the car is immobilised. Given that I could start any 850 within about 1 minute, even with the immobiliser set, a determined and knowledgeable thief shouldnt have too much problem!
checked in line fuse and it was not like one guy showed on picture.
Mine was bolted on both side with 10mm bolt and nut. It was OK.

I checked battery voltage and it was 12.4V, I connected big battery charger to give 13.4V
and it did not make any change.

I disconnected 2 Motronics, EML , EGS and SW on, still could not read PEAKE.

Somebody suggested ignition SW, but I could not imagine ignition Sw is faulty.

So what's left ????
>>> disconnect the modules connected to the TDX and RDX lines one by one
>>> and check if the Peake starts to read the codes again
>>> this should be the simplest way to isolate the "bad" module -- no
>>> need to start the engine
>>> I hope this plan works
>>> Mike


>> This is actually what I did (disconnect and replace do not make any
>> difference as long as component is good)
>> I swapped every component one by one and when engine does not start,
>> Peake could not read the codes.
I cut 2 wires to DME pin 81 and no success"
My 850 problem looks like same as Chris B's problem on Roadfry
I sent him e-mail asking what was the cause but no reply.

Hi Erich, Mike

E31 problem was finally solved.
It was a fusible link in trunk room in series of red thick wire.

This was suggested many times and I thought I checked many times but
there were 2 fuses in trunk room.
One fuse was in black plastic square box in series of red wire bolted
and I thought this was what every body suggesting.

After I started voltage check at EML and DME connectors with key on, I
found some pin's voltage were not right. They supposed to be 12V but showed very low voltage.
I traced it by circuit diagram and it connect to 12V terminal in E-box
at front right engine room.
Voltage measured was very low and circuit diagram shows it connect
fusible link (50A) and to battery.
I checked in trunk room and battery very carefully this time and found
two red wire was connected to battery. One was connected to fuse in black plastic box and the other was covered together with main cable with black sleeve. In the sleeve, there was some projection and when battery is connected and I twisted this part, it made relay on/off noise.
At this time, I realized there is something inside the sleeve.
I cut the sleeve and there was another sleeve covering red wire, Fusible
link was inside this sleeve.
Fuse was cut(open) at the edge(both side was connected by eyelet).
I soldered cut side and everything was fine.
I should have started with voltage check in the beginning.
I learned basic is very important.