Results 1 to 7 of 7

Thread: Got my 3rd E34,need some help on diagnosis

  1. #1
    Join Date
    Jul 2006
    Posts
    100

    Default Got my 3rd E34,need some help on diagnosis

    Just got her today, 1992 525i 5 speed with 117,000 mileage. I'll post some pics soon, got her in a good condition everything working well I would say except for the rough idle. I've search on some thread but mine I guess not that complicated. Steadly idling at 800 rpm but rough, as you rev until 3500 rpm is rough whether it be standing rev or moving rev is rough but once you pass 3500 up to 6000 it's smooth as if no problem with it. Look at the MPG, consuming 9 MPG. The previous owner says needs to replace 2 of it's igniter(I'm not sure if what he meant was the coil).The car had been garaged and never started for 4 months not until today when I purchased it.I'm not sure of my diagnosis isn't it rough at low rpm could be fuel issues and like stalling or rough at high rpm its electrical. I plan to change the plugs, rotor, wires & cap. Is there any other parts I should prioritize to change and look into?
    Greatly appreciate any input at this point.

  2. #2
    Join Date
    Sep 2006
    Location
    Overpelt Belgium
    Posts
    104

    Default

    If you have VANOS on it,i woult check this allso.There are some storys about problems with VANOS.
    Allso check the waterpump if it is replaced.Otherwise,just in case, chance it.That is a 30 min job.

    Congratulations with your new car



  3. #3
    Join Date
    Jun 2005
    Posts
    202

    Default

    Quote Originally Posted by takumidrift30
    Just got her today, 1992 525i 5 speed with 117,000 mileage. I'll post some pics soon, got her in a good condition everything working well I would say except for the rough idle. I've search on some thread but mine I guess not that complicated. Steadly idling at 800 rpm but rough, as you rev until 3500 rpm is rough whether it be standing rev or moving rev is rough but once you pass 3500 up to 6000 it's smooth as if no problem with it. Look at the MPG, consuming 9 MPG. The previous owner says needs to replace 2 of it's igniter(I'm not sure if what he meant was the coil).The car had been garaged and never started for 4 months not until today when I purchased it.I'm not sure of my diagnosis isn't it rough at low rpm could be fuel issues and like stalling or rough at high rpm its electrical. I plan to change the plugs, rotor, wires & cap. Is there any other parts I should prioritize to change and look into?
    Greatly appreciate any input at this point.
    By ignitors he might have meant spark plugs. Try them first because they're cheaper. 4 months without driving? Might just need some fresh gas. If you have access to BG products you might try a can of 44k, it does wonders, or use a good injector cleaner like Techron with about a half tank of gas.

    Paul

  4. #4
    Join Date
    Mar 2006
    Location
    Derbyshire, UK
    Posts
    871

    Default

    Quote Originally Posted by takumidrift30
    Steadly idling at 800 rpm but rough, as you rev until 3500 rpm is rough whether it be standing rev or moving rev is rough but once you pass 3500 up to 6000 it's smooth as if no problem with it.
    Examine the intake boot, the rubber tube that links the AFM to the throttle body. Feel for cracks where the PCV pipe connects on the left, and/or the ICV pipe on the right. If so, replace it and the ICV pipe. These are cheap, and your idle and oil consumption (if any) will improve. New spark plugs will probably clean up the idle entirely.

    Quote Originally Posted by takumidrift30
    I plan to change the plugs, rotor, wires & cap
    It should be an M50 engine, which has no rotor, wires, and cap. It has six coils under the plastic engine cover. Remove this (you'll have to to change the plugs) and you can check if a leaky valve cover has been dumping oil into the plug wells.

    1997 535i V8
    5spd, OBC, A/C, cruise, BMW phone, factory M-Tech wheel & suspension, 18" Alpinas

  5. #5
    Join Date
    Jul 2006
    Posts
    100

    Default

    Sorry for the late reply was out of town since last week, didn't have any internet access. First greatly appreciate all the inputs, thanks again guys! Ok, here's what I did, checked all the hoses everything is ok and no cracks, then changed the plugs (didn't see any oil on the plug wells) basically improved but not significant-had a smoother idle but the sound is like misfiring at any RPM. Decided to pull out the ignition coils from my other 525i and put them one by one to identify exactly which specific coil is the problem, it turned out the 1,2,3 coils are bad had a smoother idle and at high RPM. But a certain point still a little of roughness, are there any other areas I should look into the engine? Is ok to change only the 3 ignition coils or I should change all 6?
    Gtopaul, apologies for my ignorance what are BG products and 44K? I also put fresh gas to it and fuel injector cleaner.
    CarloE34 thanks again!

  6. #6
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default

    its a good injector cleaner.
    Quote Originally Posted by takumidrift30
    BG products 44K
    CarloE34 thanks again!
    next step would be the plug boots.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  7. #7
    Join Date
    Jul 2006
    Posts
    100

    Default

    Quote Originally Posted by 632 Regal
    its a good injector cleaner. next step would be the plug boots.
    Thanks again! Ok bought 3 new ignition coil today and installed them, got a smooth idle, improved a lot. The thing now is from 1,500 rpm to 2,500 has a rough rev, pass by that up to 6,000 rpm have a smooth rev. Changed fuel filter drove it a few miles still have the same problem.
    Anymore areas I should look into?

Similar Threads

  1. Car Died. Diagnosis?
    By liquidtiger720 in forum 5 Series BMW
    Replies: 56
    Last Post: 10-11-2006, 09:21 PM
  2. Clutch diagnosis help
    By dbals in forum 5 Series BMW
    Replies: 1
    Last Post: 07-05-2006, 07:09 PM
  3. Control Arm Diagnosis
    By IN10CT in forum 5 Series BMW
    Replies: 1
    Last Post: 06-11-2006, 04:12 PM
  4. E34 ABS light diagnosis
    By UK E34 in forum 5 Series BMW
    Replies: 7
    Last Post: 10-12-2004, 06:39 AM
  5. Need Help with Shimmy Diagnosis (Long)
    By talltorontoguy in forum Suspension & Steering
    Replies: 3
    Last Post: 04-26-2004, 11:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •