Page 5 of 5 FirstFirst ... 345
Results 41 to 43 of 43

Thread: stumped on 50-60mph shimmy

  1. #41
    Join Date
    Feb 2004
    Location
    Missouri, USA
    Posts
    136

    Default Clink can equal sway bar end link(s).....

    Quote Originally Posted by jplacson
    It's more of a mild 'clink' than a 'clunk' really. It might be the collar nut, I haven't checked that one yet... could it also be a ball joint, or the steering box moutning bolts?
    Cheap/easy fix.
    You really ought to see how all that spindle/strut/Thrust Arm/lower control arm pivots when you turn it!
    Talk about bizarre!
    I installed tie rods yesterday and observed it with the tie rod off.

    That Sway Bar end link takes a HUGE twist when the wheel is turned.....
    Clink? You bet!
    I replaced my end links weeks ago.
    EASY....as long as the nuts come loose without a fuss.

  2. #42
    Join Date
    Feb 2004
    Location
    Philippines
    Posts
    474

    Default

    Ok thanks! Will be bringing into the shop that did the front end a month ago...it's still under warranty, and if any of the parts they changed are broken, or they installed it wrong... they should replace it all for free.

    In any case, I'm gonna bring it to another indy shop that specializes in European suspensions... just for a 2nd opinion... I won't tell 'em what I had done, or what the problem is first... I wanna see what they have to say.

    It's just a mild shimmy..no where near as bad as it was before. It doesn't shimmy anymore under any kind of braking. Only from 50-60mph. Will see. I'm also sourcing some hubcentric rings just in case.

  3. #43

    Default

    I just got back from my BMW stealer today after a botched alignment. It was a few degrees out of align - it still didn't correct my shimmy. Like most others, it comes on a 50 and disappears at 60. I've been hunting my shimmy for over a year now. Here's what I've replaced:

    Thrust arms
    Lower control arms - Replaced my aluminum ones w/ steel - No difference!
    Sway bar end links
    Tie rods
    Shocks - Front/Rear
    Rotors/pads
    Brand new tires
    Hunter GSP9700 balance
    I'm using hubcentric rings on 17" M5 replicas (not bent!)

    After replacing all of this.... I still have my damn shimmy!!!

    Well after talking w/ BMW techs today, they recommended I change out my center support bearing and driveshaft. They'll do it for $1323!! I'll probably get a guibo and center bearing ordered today from Patrick... BTW my car has 125,000 miles so I figure it's ready for it anyway. Hopefully this will correct it!!

    Thanks for all the help guys!!
    94 540iA w/ EAT
    97 740iL (SOLD!)
    99 Discovery II

Page 5 of 5 FirstFirst ... 345

Similar Threads

  1. 55-60mph shimmy
    By Scott C in forum 5 Series BMW
    Replies: 0
    Last Post: 04-24-2010, 01:18 PM
  2. Replies: 14
    Last Post: 08-02-2009, 05:00 PM
  3. Im stumped!!
    By brianwolf3 in forum 5 Series BMW
    Replies: 5
    Last Post: 02-11-2007, 04:04 PM
  4. Damn 50-60mph shimmy!!!! :-(
    By UK E34 in forum 5 Series BMW
    Replies: 8
    Last Post: 07-24-2005, 12:37 PM
  5. 60mph shimmy
    By warmboy in forum 5 Series BMW
    Replies: 1
    Last Post: 04-26-2004, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •