Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: 94 530iA slow from a stop

  1. #1

    Default 94 530iA slow from a stop

    My 94 530i automatic is scaring me. Merging into traffic has become a chore because I dont get any real power until the high rpms. It feels like the car is skipping first gear and that i'm in second from a stop. Can someone tell me why it is like this. The engine is running perfectly and is brand new. I took it to the dragway and my best was an 18.3 @ 82mph

    Are they all like this? The car cant even spin the tires from a stop when its wet. Someone please help.. No codes although I did get a trans program light a few weeks ago, but it went away. I think the car has been like this since it was bought but i'm not sure as it was my brothers. Tranny has 212k miles on it lol


    thanks

  2. #2
    Join Date
    Mar 2005
    Location
    Hockinson, Washington
    Posts
    2,499

    Default

    I can safely say that that is not normal, other than that, i havent got anyting.
    Lowered with blue h&r(?) springs, Bilsteins, tint, 19# design 3 injectors, Dual Magnaflow
    southwest WA

  3. #3
    Join Date
    Mar 2005
    Location
    Washington DC
    Posts
    120

    Default

    Mine brakes out when it is wet. One time when it torqued up the fan ate part of my upper radiator hose.

  4. #4
    Join Date
    May 2005
    Location
    central coast nsw au
    Posts
    1,221

    Default

    sorry to hear it mate but mine felt the same a few weeks ago. had the box rebuilt! do a search as it might not be so drastic as what i would not want it to be. Best of luck

  5. #5
    Join Date
    Oct 2004
    Location
    Gainesville, FL
    Posts
    549

    Default

    I'm going to say that's the way they are. As an owner i can tell you that it's driven exactly how you say, like its starting in 2nd gear, for at least 10 years of its 12 year life. I hardly could blame the transmission.

    I've never driven a car that's accelerated below 35mph this slow in my life, except for the shitty GMC sonoma we have at work.

    I guess maybe the transmission could be broken.. somehow?

    Don't worry, you'll get used to it Just put it in S4 or S3 and floor it, it moves, it just takes a second.

    Its a 4000lb car with an automatic meant for relaxing driving. I don't think you could spin the wheels if you coated them in oil and drove the thing on glass.

  6. #6
    Join Date
    Apr 2005
    Location
    Philadelphia
    Posts
    805

    Default

    Hmm... I dunno about that... Mine accelerates pretty darn quick off of a stop. The only problem I have with merging is that I end up on the freeway faster than expected, leaving the other cars far behind. With ACS off, dumb yes but i've tried it, I can definitely spin the tires in a small pool of water. Yes, Sport mode does increase the acceleration, especially when floored. But as far as pulling off being slow or having the "2nd gear" feeling... I'm not having that problem at all.
    Rondell 58's|Eibach Springs|B&B Tri-Flow Exhaust|Shadowline|S/D Rotors|KYB Struts



  7. #7
    Join Date
    Mar 2005
    Location
    Washington DC
    Posts
    120

    Default

    I have spun mine on a wet road with traction on. JT540i can confirm this one. I was on my way to his house when the fan nicked the hose.

  8. #8
    Join Date
    Apr 2005
    Location
    Philadelphia
    Posts
    805

    Default

    Quote Originally Posted by Eric Clark
    I have spun mine on a wet road with traction on. JT540i can confirm this one. I was on my way to his house when the fan nicked the hose.
    Yea... A few times here as well, with the little ACS light popping on as the wheels redistribute speed. I've seen no power issues with mine in this regard.
    Rondell 58's|Eibach Springs|B&B Tri-Flow Exhaust|Shadowline|S/D Rotors|KYB Struts



  9. #9
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,723

    Default

    real turds below 4000 rpms, Mark is working in a chip for us. his last beta chip caused mine to spin the tires fron a standstill but had a few issues with our transmissions. He sent me another chip that is much better than stock but will take a bit till we zero in a final version.

    a new gear ratio of 3:64 helps immensly in city driving and acceleration.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  10. #10
    Join Date
    Apr 2005
    Location
    Philadelphia
    Posts
    805

    Default

    Quote Originally Posted by 632 Regal
    real turds below 4000 rpms, Mark is working in a chip for us. his last beta chip caused mine to spin the tires fron a standstill but had a few issues with our transmissions. He sent me another chip that is much better than stock but will take a bit till we zero in a final version.

    a new gear ratio of 3:64 helps immensly in city driving and acceleration.
    Sign me up for that chip with the final version is complete! What's the asking price? $250?
    Rondell 58's|Eibach Springs|B&B Tri-Flow Exhaust|Shadowline|S/D Rotors|KYB Struts



Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 13
    Last Post: 12-30-2007, 03:36 PM
  2. Ebay Chip for 530ia
    By e34musician in forum 5 Series BMW
    Replies: 8
    Last Post: 04-12-2007, 10:55 PM
  3. 530iA spare parts
    By jpkasper in forum 5 Series BMW
    Replies: 2
    Last Post: 12-24-2006, 12:36 AM
  4. EAT Chip for the 530ia?
    By Boone.Msi in forum 5 Series BMW
    Replies: 10
    Last Post: 11-26-2006, 04:39 PM
  5. ::.. 2001 BMW 530iA
    By Qube in forum 5 Series BMW
    Replies: 10
    Last Post: 07-25-2006, 11:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •