Results 1 to 2 of 2

Thread: no air from climate control

  1. #1
    Join Date
    Mar 2006
    Location
    Wuerzburg, Germany
    Posts
    16

    Default no air from climate control

    ever since i bought the car a few months ago, i can't get the climate control to work correctly. The fan comes on, on all speeds, and i can change the flaps to make it come fromt the different vents, but no matter how high of a speed the fan is on, i get almost no air flow. I've checked in the intake below the windshield and it's clear. Anything else to check? Thanks.
    1992 525i (Euro spec, 5-speed, cloth seats, manual windows, wheel covers...)
    At home, in storage:
    1994 Audi S4 (not so stock)
    1983 Honda CB650SC

  2. #2
    Join Date
    Mar 2006
    Location
    Derbyshire, UK
    Posts
    871

    Default

    Last edited by DaveVoorhis; 06-05-2006 at 03:35 AM.

    1997 535i V8
    5spd, OBC, A/C, cruise, BMW phone, factory M-Tech wheel & suspension, 18" Alpinas

Similar Threads

  1. Climate Control
    By Jerry Neri in forum 5 Series BMW
    Replies: 1
    Last Post: 05-16-2009, 07:18 PM
  2. 92 735 climate control
    By Visions in forum 7 Series BMW
    Replies: 10
    Last Post: 10-27-2006, 07:07 PM
  3. Replies: 4
    Last Post: 01-04-2006, 02:11 PM
  4. Climate control fan speed on '94 car
    By system11 in forum 5 Series BMW
    Replies: 8
    Last Post: 10-06-2004, 06:19 AM
  5. Climate Control Lighting
    By JR'Z 525 in forum 5 Series BMW
    Replies: 3
    Last Post: 06-12-2004, 12:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •