Results 1 to 9 of 9

Thread: Did ALL E34s come with ABS as standard?

  1. #1
    Join Date
    Feb 2004
    Location
    Philippines
    Posts
    474

    Default Did ALL E34s come with ABS as standard?

    I'm not sure if mine came with ABS or not, it's a '89 Euro version. The ABS dashlight never comes on when I start up the car (but a lot of lights really don't light up as well...like the 'gear selection for automatics' since mine is a manual) ... my instrument cluster seems to have a lot of empty slots for other models (like a diesel preglow indicator) so I don't know if the ABS light is busted or not... while my car is in the shop I wanted to have it checked.

    Is there a way for me to check if I have ABS or if my ABS is working or not? I want to know what to tell the guys at the shop...just in case they don't know what to do either. Thanks!

  2. #2
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,923

    Default

    not sure about the rest of the world but in the us all bimmers after 86 had abs, you can see the pump in the pic of my car, it's right below the red dipstick in the pic, bottom center, it's the thing with all of the metal pipes going from and to it
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  3. #3
    Join Date
    Dec 2003
    Location
    Wellington,New Zealand
    Posts
    3,868

    Default the ABS unit is the aluminium box

    to the right and below the oil filter cannister.I am pretty sure it ABS cast into it
    Gone but not forgotten

  4. #4
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,923

    Default

    that's the early 4 channel pump, mine is the later 3 channel pump (one less line going out, one for both rear brakes)
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  5. #5
    Join Date
    Dec 2003
    Location
    Wellington,New Zealand
    Posts
    3,868

    Default yeah mine is a relatively early car....manf 1989 nt

    :d
    Gone but not forgotten

  6. #6
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,923

    Default

    mines a 9/89 but i added the later pump when i installed the 92 525 wiring harness i had to install the later system to be compatable with the harness (my car was a interior burn and i updated it with later goodys, stereo, microfilter style hvac system with the resister pack and not the sword, among other stuff)
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  7. #7
    Join Date
    Feb 2004
    Location
    Philippines
    Posts
    474

    Default

    Thanks guys! Will check my engine bay!

  8. #8
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    27

    Default bulbs in the dashboard

    jp,

    replacing the bulbs are quite easy..i thought they were difficult..just remove the steering wheel..be sure to follow airbag removal instructions if you have one..mine did not..it is also recommended that you replce the self locking nut once it is removed inside the steering wheel..i did not..jsut make sure if you do not replace it with a new nut..make sure it is secured tightly.the instrument cluster is held on the dash by 2 mounting screws at the top of the cluster..you have to peer upwards to notiuce them as they are quite small..from here on its easy..just pull the inst cluster out and check the bulbs one by one..dad has two 635 and 630 spare inst cluster boards and i just used the bulbs..sort of cannibalized his 1.2&3watt spare bulbs..they all work now..

    ed.

    Quote Originally Posted by jplacson
    Thanks guys! Will check my engine bay!

  9. #9
    Join Date
    Feb 2004
    Location
    Philippines
    Posts
    474

    Default

    Thanks Ed! Well, first I have to check if I do have ABS to begin with! Kinda pointless to replace a bulb that isn't connected to anything! HAHAHA!

Similar Threads

  1. ot: why I don't drive a standard
    By tim eh? in forum 5 Series BMW
    Replies: 8
    Last Post: 06-03-2010, 09:21 AM
  2. hub rings - standard size?
    By choccibicci in forum 5 Series BMW
    Replies: 5
    Last Post: 08-08-2007, 08:08 PM
  3. m5 diff in a standard 525i?
    By filip00 in forum 5 Series BMW
    Replies: 7
    Last Post: 07-16-2007, 05:36 AM
  4. does anyone know what this BMW standard is?
    By rob101 in forum 5 Series BMW
    Replies: 11
    Last Post: 07-24-2006, 09:19 PM
  5. What is the difference between M and standard
    By ThoreauHD in forum 5 Series BMW
    Replies: 22
    Last Post: 04-15-2006, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •