Results 1 to 6 of 6

Thread: A/c stopped working

  1. #1

    Default A/c stopped working

    The A/C in my 97 540 stopped working a few days ago. The blower works great. The A/C compressor goes on when I hit the A/C button.

    What to look for? Should i take it to a A/C specialist for diagnosis?

  2. #2
    Join Date
    Mar 2005
    Location
    Long Beach, CA
    Posts
    2,563

    Default

    Quote Originally Posted by DukeNeverwinter
    The A/C in my 97 540 stopped working a few days ago. The blower works great. The A/C compressor goes on when I hit the A/C button.

    What to look for? Should i take it to a A/C specialist for diagnosis?
    Are you sure you don't have the temps on warm or the center vent on red? Sorry to ask, but I've done it before.

    Ralph Mendoza Jr. - Long Beach, CA

  3. #3

    Default

    I have tried different temps from 70 to 62. no differnece. I'll check the vent but I think I have it set to blue.

  4. #4
    Join Date
    Mar 2005
    Location
    Bethlehem, PA
    Posts
    661

    Default

    The A/C in the E39 is a relatively touchy affair. The refrigerant charge is very small and performance is sensitive to slight changes. Your system probably developed a small leak that bled off enough charge to impact the performance, but not enough to cause the underpressure limit switch to disable the compressor. IMO you're facing a trip to an A/C specialist to find the leak and recharge the system. BMW does not support charging the system by any method other than weighing in the charge to an evacuated system.

    If it were my car, it would go to the dealer.

  5. #5

    Default

    I have a friend that is familiar with a/c systems. He has all the dials and gauges and stuff. I'll will contact him and just refill at first then. If it leaks out within a short time, i'll take itto a shop. SInce it is r134a i can;t see it being that much diferent than other cars.

  6. #6
    Join Date
    Mar 2005
    Location
    Bethlehem, PA
    Posts
    661

    Default

    What I'm saying to you is that you can't adjust charge in the E39 a/c system with "dials, gauges, and stuff." You could add dye to find a leak, and introduce a bit of refrigerant in the process. But after the leak is fixed, the only way to charge the system to BMW specifications is by evacuation and weight. And when you're talking about (this is from my E39) 1.65 lb +- .02 lb it ain't exactly a trivial task.

    Besides, the presence of a leak is only speculation at this point. I suppose it wouldn't hurt to connect up the gauges to do a pressure/temperature sanity check. If you're pulling 100psi on the suction side, for example, it's not a charge problem.

Similar Threads

  1. Windshield Washer Stopped Working
    By nirvana19 in forum 5 Series BMW
    Replies: 6
    Last Post: 03-01-2008, 12:31 PM
  2. Horn Stopped working...!?
    By Ferret in forum 5 Series BMW
    Replies: 10
    Last Post: 09-11-2007, 12:44 PM
  3. Alpine remote stopped working
    By azzurribaggio in forum 5 Series BMW
    Replies: 2
    Last Post: 06-12-2006, 05:05 AM
  4. Bmw (525tds)'95---sunroof stopped working...
    By jesax in forum 5 Series BMW
    Replies: 4
    Last Post: 04-30-2005, 07:44 PM
  5. Rear window stopped working...
    By myblack540i in forum 5 Series BMW
    Replies: 2
    Last Post: 09-21-2004, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •