Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: my e34 ac/fan only works on setting 4? help please....

  1. #1
    Join Date
    Jul 2005
    Location
    east bay area
    Posts
    67

    Default my e34 ac/fan only works on setting 4? help please....

    has anyone every have this problem before.....

    please let me know if there is a way to fix it.

    thanks

  2. #2
    Join Date
    Jul 2005
    Location
    Cologne, Germany
    Posts
    131

    Default

    resistor box or blower switch blown
    greets from Germany,
    Kai


    A BMW is a black car with most rights in road traffic.

  3. #3
    Join Date
    Jan 2004
    Location
    Apex, NC
    Posts
    471

    Default

    Blower resisitor or sword. What year, model, etc..?
    Scott
    '93 525iT 245k miles (sold, but not forgotten)
    '11 TSX Sport Wagon
    '00 328i
    '78 MGB
    '08 Saab Aero


  4. #4
    Join Date
    Mar 2005
    Location
    Long Beach, CA
    Posts
    2,563

    Default

    Quote Originally Posted by ScottyWM
    Blower resisitor or sword. What year, model, etc..?
    You should edit your profile to show the details on your car so we can better help with your car.

    Ralph Mendoza Jr. - Long Beach, CA

  5. #5
    Join Date
    Feb 2004
    Location
    Minnesota
    Posts
    499

    Default

    Quote Originally Posted by uscharalph
    You should edit your profile to show the details on your car so we can better help with your car.
    great idea Ralph! I think Young Pete might have a M50 which likely will be the resistor pack under the panel above your knees on left hand drive cars. If it is resistor pack then you're lucky cuz if it is the "sword" it is tougher to get at and more expensive to replace!
    Listen to the guys Young Pete, change your profile to reflect your car, engine, tranny type, at least. Responses will come faster and more willingly, I think.
    JonE

  6. #6
    Join Date
    Jul 2005
    Location
    east bay area
    Posts
    67

    Default

    Quote Originally Posted by JonE
    great idea Ralph! I think Young Pete might have a M50 which likely will be the resistor pack under the panel above your knees on left hand drive cars. If it is resistor pack then you're lucky cuz if it is the "sword" it is tougher to get at and more expensive to replace!
    Listen to the guys Young Pete, change your profile to reflect your car, engine, tranny type, at least. Responses will come faster and more willingly, I think.
    JonE

    is this easy to replace? i have a feeling im gonna need a heater soon.........

  7. #7
    Join Date
    Jun 2005
    Location
    New York City
    Posts
    48

    Default

    Your problem is definitely with the resistor pack. In earlier models it is also known as the "sword". A sword can cost up to $120 and is slightly more difficult to replace. The resistor pack (i think your car uses the resistor pack) costs about $13 and is very easy to install. Simply removed the old resistor pack (located under the steering wheel and to the right) and snap the new one in. You can call BMA or another BMW parts dealer and they should be able to give you further instructions.

  8. #8
    Join Date
    Jul 2005
    Location
    anaheim ,ca
    Posts
    29

    Default

    Quote Originally Posted by nyc525iTe34
    Your problem is definitely with the resistor pack. In earlier models it is also known as the "sword". A sword can cost up to $120 and is slightly more difficult to replace. The resistor pack (i think your car uses the resistor pack) costs about $13 and is very easy to install. Simply removed the old resistor pack (located under the steering wheel and to the right) and snap the new one in. You can call BMA or another BMW parts dealer and they should be able to give you further instructions.
    can you guys describe how it looks like? thanks.

  9. #9
    Join Date
    Oct 2004
    Location
    Gainesville, FL
    Posts
    549

    Default

    where did that sticky post for newbies go? i bet this was in there.

  10. #10
    Join Date
    Jun 2005
    Location
    New York City
    Posts
    48

    Default

    If you go to this link http://www.bmwe34.net/ and look up "sword" or "resistor pack" you should be able to find more information about this issue.

Page 1 of 2 12 LastLast

Similar Threads

  1. HELP! Low Rev Limiter Setting.
    By foxese34 in forum 5 Series BMW
    Replies: 3
    Last Post: 08-20-2008, 03:45 PM
  2. Help, re-setting service indicator
    By Rich 525i in forum 5 Series BMW
    Replies: 18
    Last Post: 08-28-2006, 11:27 AM
  3. setting timming for M30
    By grave77 in forum 5 Series BMW
    Replies: 8
    Last Post: 12-25-2005, 11:50 AM
  4. Setting E34 Factory Alarm?
    By wishihad50k in forum 5 Series BMW
    Replies: 2
    Last Post: 04-14-2005, 10:08 AM
  5. Setting up ETK on new computer?
    By Bryan in Coral Springs in forum 5 Series BMW
    Replies: 5
    Last Post: 09-28-2004, 09:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •