Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: 540i/a running rough continue's

  1. #1
    Join Date
    Jan 2004
    Location
    SCHUYLKILL COUNTY, PA.
    Posts
    571

    Default 540i/a running rough continue's

    my 540i/a is still running rough. i had the local dealer check it out today. their computer found no fault codes at all. they suggested it could be bad motor mounts. has anyone else had a problem with bad motor mounts causing a rough vibration in the car. it is worse around 1300 r.p.m.
    thanks
    tim s.
    1995 540i/a
    1987 325e

  2. #2
    Join Date
    Dec 2003
    Posts
    36

    Default

    Do you have a rough idle when warm, cold? How many miles? Have the O2 sensors been replaced? Also could be a vacuum leak.

    AA
    95 540iA, 108kmiles

  3. #3
    Join Date
    Jan 2004
    Location
    SCHUYLKILL COUNTY, PA.
    Posts
    571

    Default new o2's, 180,000 , does it all the time, dealer says no vaccum leaks.

    Quote Originally Posted by AA540
    Do you have a rough idle when warm, cold? How many miles? Have the O2 sensors been replaced? Also could be a vacuum leak.

    AA
    95 540iA, 108kmiles

  4. #4
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    i am starting to learn that the pcv plate can be the root of all evel on v8s, it's like $30 at the dealer and will make it do some strange ****, it may not be the problem but it can be a weird problem trust me, we had a 95 740 whip chuck and my ass last week, chuck is a seasoned ase master tech and i like to think i have a little on the ball, we poured over that son of a bitch for a week and a half
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  5. #5
    Join Date
    Jan 2004
    Location
    SCHUYLKILL COUNTY, PA.
    Posts
    571

    Default what problem did you have with the pcv plate?

    Quote Originally Posted by winfred
    i am starting to learn that the pcv plate can be the root of all evel on v8s, it's like $30 at the dealer and will make it do some strange ****, it may not be the problem but it can be a weird problem trust me, we had a 95 740 whip chuck and my ass last week, chuck is a seasoned ase master tech and i like to think i have a little on the ball, we poured over that son of a bitch for a week and a half

  6. #6
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    it got to the point that it couldn't get to 40 mph, a crappy idle, a intermittent miss and one thing that was really weird, the computer was trimming the mixture 25% lean on one bank and 25% rich on the other from the baseline running setting, we could reset the computer and it would be screwed back up in a couple miles of driving, another weird point no check engine light. there was no external vaccum leak, all internal
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  7. #7
    Join Date
    Jan 2004
    Location
    SCHUYLKILL COUNTY, PA.
    Posts
    571

    Default thanks, how can i check to see if this is my problem?

    Quote Originally Posted by winfred
    it got to the point that it couldn't get to 40 mph, a crappy idle, a intermittent miss and one thing that was really weird, the computer was trimming the mixture 25% lean on one bank and 25% rich on the other from the baseline running setting, we could reset the computer and it would be screwed back up in a couple miles of driving, another weird point no check engine light

  8. #8
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    change the piece of crap
    all america wants is cold beer warm cat and a place to take a poop with a door on it

  9. #9
    Join Date
    Jan 2004
    Location
    SCHUYLKILL COUNTY, PA.
    Posts
    571

    Default do you have a pic & how much are they?

    Quote Originally Posted by winfred
    change the piece of crap

  10. #10
    Join Date
    Dec 2003
    Location
    baton rouge, loserana
    Posts
    6,922

    Default

    about $30

    all america wants is cold beer warm cat and a place to take a poop with a door on it

Page 1 of 2 12 LastLast

Similar Threads

  1. running rough
    By edward in forum 5 Series BMW
    Replies: 3
    Last Post: 05-16-2009, 10:30 PM
  2. rough running
    By jippijak in forum 5 Series BMW
    Replies: 1
    Last Post: 02-26-2006, 04:46 PM
  3. help, 540i/a still running rough
    By tim s in forum 5 Series BMW
    Replies: 4
    Last Post: 03-30-2004, 01:19 PM
  4. 540i/a running rough!!! please help!!!
    By tim s in forum 5 Series BMW
    Replies: 4
    Last Post: 02-21-2004, 03:37 PM
  5. Please Help!!! 540i/a running rough
    By tim s in forum 5 Series BMW
    Replies: 4
    Last Post: 02-19-2004, 04:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •