Results 1 to 9 of 9

Thread: Problem Solved Finally!!!???

  1. #1
    Join Date
    Jan 2005
    Location
    Sicily
    Posts
    188

    Default Problem Solved Finally!!!???

    Thanks for everyones help and suggestions, my mysterious noise was the POWER STEERING PUMP. It appears the old self leveling removal wasnt plugged right it was causing the noise the whole time.

  2. #2
    Join Date
    Nov 2004
    Location
    Winston-Salem, NC
    Posts
    603

    Default

    Quote Originally Posted by e34it
    Thanks for everyones help and suggestions, my mysterious noise was the POWER STEERING PUMP. It appears the old self leveling removal wasnt plugged right it was causing the noise the whole time.
    CONGRATS on finding the problem!!!

    -ashley


    '92 525iA / 179k miles / Born 3.92 / ABS / No ASC / stock / North Carolina



    Paper Gaskets Suck!

  3. #3
    Join Date
    Aug 2004
    Posts
    135

    Default

    hey man can you tell me exactrly what u did
    i think i have the same noice for over 2 weeks i get this noice at serten RPM and only when it gets hot

  4. #4
    Join Date
    Jan 2004
    Location
    Calgary AB Canada
    Posts
    589

    Default Good news

    Quote Originally Posted by e34it
    Thanks for everyones help and suggestions, my mysterious noise was the POWER STEERING PUMP. It appears the old self leveling removal wasnt plugged right it was causing the noise the whole time.
    This issue has been discussed on the M5 group. When you disable the SLS, the supply and return lines need to be connected together rather than plugged. This can be done either at the pump or at the rear of the car.

    If you plug the line the pump is driving into the plugged line creating high static pressure rather than allowing the fluid to simply circulate with no pressure.

    Anthony
    Anthony
    03/64 production

    '91M5 - 11/90, was mine, it's Jim's now.

  5. #5
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,728

    Default

    Sweet! I knew it had to be simple after them clues you gave and mentioned self leveling removal.
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  6. #6
    Join Date
    Jan 2005
    Location
    Sicily
    Posts
    188

    Default

    ve39, i dont think your car has self leveling so that wouldnt be the problem, check your lines, and your ps pump, bleed it if need be.

  7. #7
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,728

    Default it dont anymore!

    Quote Originally Posted by e34it
    ve39, i dont think your car has self leveling so that wouldnt be the problem, check your lines, and your ps pump, bleed it if need be.
    .
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  8. #8
    Join Date
    Aug 2004
    Posts
    135

    Default

    sorry explain lines and ps pump not good with english car terms

  9. #9
    Join Date
    Dec 2003
    Location
    Wellington,New Zealand
    Posts
    3,868

    Default

    power steering pump and the hoses that run to it and from it....
    Gone but not forgotten

Similar Threads

  1. Solved my E34 surging problem...
    By onZedge in forum 5 Series BMW
    Replies: 3
    Last Post: 09-01-2007, 10:44 PM
  2. Problem Solved!
    By cableface in forum 5 Series BMW
    Replies: 6
    Last Post: 06-18-2006, 08:35 AM
  3. Replies: 6
    Last Post: 05-05-2004, 12:19 AM
  4. Finally solved the Check Engine Light (1221 code)
    By Erick in forum 5 Series BMW
    Replies: 2
    Last Post: 05-04-2004, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •