Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Help, re-setting service indicator

  1. #1
    Join Date
    May 2005
    Location
    Oxford, UK
    Posts
    2

    Default please Help, re-setting service indicator

    Hi, this is my first post so sorry if its not very clear.

    I've had my 93 525i sport for a few months. It needed a stage II service so I had it done at the local garage but I need to re-set the onboard computer, it still comes up with the orange and red service light when I turn it on.

    It also sometimes comes up with tail light, number plate light, brake pads randomly but they are all working fine.

    Can you tell me how to do it? I have heard it is relitively easy.

    Rich
    Last edited by Rich 525i; 05-05-2005 at 09:27 AM.

  2. #2
    ukm5 Guest

    Default

    this link will tell you how to reset properly
    http://www.homeofsbc.com/Hints/Reset...t_the_sil.html

  3. #3
    Join Date
    May 2004
    Location
    Sydney, Australia
    Posts
    2,699

  4. #4
    Join Date
    Feb 2004
    Location
    Minnesota
    Posts
    499

    Default

    I think it's normal for the light bars to be on briefly at start-up after a reset. Then, over time less and less bars show up at start-up until "service" appears. Maybe I'm wrong on this, I think it's different between my E30 and the E34?

  5. #5
    Join Date
    Dec 2003
    Location
    Eastern Tennessee USi
    Posts
    14,781

    Default uh ohhh

    Quote Originally Posted by Rich 525i
    It also sometimes comes up with tail light, number plate light, brake pads randomly but they are all working fine.
    Gremlins?
    95 E34 530I V2.37
    ===========
    Those who make peaceful revolution impossible will make violent revolution inevitable.

    John F. Kennedy

  6. #6
    Join Date
    May 2005
    Location
    Tampa
    Posts
    40

    Default

    It is easy and only costs a couple $ for the parts. Go to www.unofficialbmw.com/frame_e30.html and you will see the instructions and needed parts which you can get at Radio Shack or any store that handles electrical parts.

  7. #7
    Join Date
    Jan 2004
    Location
    Maryland
    Posts
    92

    Default Light and brake pad warnings

    Your intermittent warnings may be related, but there is a good chance that they have different causes.
    Tail and License Plate light warnings - Sometimes the fault circuitry has trouble distinguishing good bulbs from bad, even new ones. Some brands of bulbs appear to have resistances closer to the threshold than others. Wagner bulbs have worked best in my BMWs.
    Brake Sensor - The sensor is designed to trip with plenty of "meat" still on the pads, so it may simply be the normal beginning of sensor wear. I customarily expereince intermittent brake pad lights when the sensor wire has just barely started wearing through. The rotor then makes contact with the wire on and off. On my E30s this is accompanied by static noise in the AM radio. I don't hear that noise on my 1995 E34, but the intermittent light has been there.
    Hope this is helpful.

    Quote Originally Posted by Rich 525i
    Hi, this is my first post so sorry if its not very clear.

    I've had my 93 525i sport for a few months. It needed a stage II service so I had it done at the local garage but I need to re-set the onboard computer, it still comes up with the orange and red service light when I turn it on.

    It also sometimes comes up with tail light, number plate light, brake pads randomly but they are all working fine.

    Can you tell me how to do it? I have heard it is relitively easy.

    Rich
    Dan Z Annapolis, MD BMWCCA Since 1986
    Sharked E30, E34, E39sprt E46xit

  8. #8
    Join Date
    Dec 2003
    Location
    NW GA
    Posts
    261

    Default

    Quote Originally Posted by JonE
    I think it's normal for the light bars to be on briefly at start-up after a reset. Then, over time less and less bars show up at start-up until "service" appears. Maybe I'm wrong on this, I think it's different between my E30 and the E34?
    Not sure if it applies to all e30's but my '88 Cabrio had a battery on the curcuit board behind the instrument cluster that once it dies and no longer recharges, the service lights come back on prematurely. It's not too bad to replace if you can solder.
    1990 535i 5-sp., except for 16" M-Contours, cd deck, and clear corners, completely stock. 226k and running strong

  9. #9
    Join Date
    Nov 2005
    Location
    Los Angeles, near Torrance
    Posts
    37

    Default

    I'm reviving this very old thread because I'm having trouble resetting the Service Indicator on my 1993 E34.

    There is a tutorial posted in this forum which recommends cutting a length of 12-gauge wire, with no inline fuse, and shorting pins 7 and 19 on the diagnostic port. Then it said to turn the ignition key to position 2 (run) and wait about 12-15 seconds for the green lights to count back up.

    I inserted one end of the wire into socket 7, and the other into socket 19--these were clearly labeled on the diagnostic port. When I turned the key to position 2, the word INSPECTION remained on, as well as the yellow indicator. I watched for about 30 seconds, but didn't see any of the green lights reappear. I've also tried this with a paperclip and with the leads on my multimeter.

    Did I do something wrong? Could it be possible that my pin 19 (ground) is bad, and that I have to ground elsewhere? I've read that the strut tower nuts are a good place to ground.

    Have I missed anything in the setup?

    Thanks in advance.

  10. #10
    Join Date
    Mar 2006
    Posts
    811

    Default

    You are attemptimg to reset the oil service indicator when the inspection indicator is active. You must reset the inspection indicator. There maybe a way to hot wire it, I always use a reset tool.

Page 1 of 2 12 LastLast

Similar Threads

  1. Service Indicator Blinking off and on
    By angusbn in forum 5 Series BMW
    Replies: 3
    Last Post: 07-30-2008, 03:01 AM
  2. Service indicator wont go off ...help plz
    By jstew4u in forum 5 Series BMW
    Replies: 1
    Last Post: 07-21-2008, 04:41 PM
  3. Service Indicator
    By Golgade in forum 5 Series BMW
    Replies: 4
    Last Post: 05-14-2008, 12:58 PM
  4. Oil Service Indicator/Yellow
    By Jehu in forum 5 Series BMW
    Replies: 10
    Last Post: 09-30-2006, 02:47 PM
  5. E36 Service indicator lights
    By Unregistered in forum 3 Series BMW
    Replies: 4
    Last Post: 05-31-2004, 02:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •